Need help on reviving my Java Moss (ashamed) - The Planted Tank Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 08-30-2012, 07:18 AM Thread Starter
Planted Tank Enthusiast
 
shrimpzoo's Avatar
 
Join Date: Sep 2011
Location: Mississauga, Ontario, Canada
Posts: 774
Need help on reviving my Java Moss (ashamed)

I've managed to kill something as simple as Java Moss and I need tips/help on trying to reviving it.

I think the reason it turned yellowish is because the light was left on for 3 days straight 24/7 ...

What should I do? I've toned down the amount of light it gets so it could "rest" but I don't know if what I'm doing is the right thing. I don't want to deprive it from light after giving it such an excess of it.

All I've done so far was dose seachem flourish comprehensive hoping that it'll make a comeback. I dosed a lot more than the recommended in hopes that it'll work its magic.

Pretty much my questions are:

1. is there any such thing as overdosing seachem flourish? should I dose according to the bottle or should I be generous so I can give my Java Moss a boost.

2. how long should I run my lights on for? for the future and for my current situation.

3. this tank I have right now is going to be a CRS breeding tank (meaning I'll be using RO to only to change water). Is the nutrients provided by seachem flourish enough for my java moss? or should I do a mix of tap water for macro nutrients.

As for now, I'll probably do a WC tomorrow with tap.

Thanks for reading and replies are appreciated.



Does my moss have a fighting chance?
shrimpzoo is online now  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 08-30-2012, 08:44 AM
Planted Tank Enthusiast
 
Join Date: May 2011
Location: Stockton,CA
Posts: 861
Thats weird. Light wont kill moss. Just makes it grow and get algaefied

Sent from my DROIDX
DerekFF is offline  
post #3 of 16 (permalink) Old 08-30-2012, 10:24 AM
Planted Tank Guru
 
acitydweller's Avatar
 
Join Date: Dec 2011
Location: New York
Posts: 7,695
leaving the light on wont turn your java moss yellow. Looks like it didnt like something in the water?

"I am Groot", the faithful protector
acitydweller is offline  
post #4 of 16 (permalink) Old 08-30-2012, 11:03 AM
OVT
Carpe Diem
 
OVT's Avatar
 
Join Date: Nov 2011
Location: SF East Bay Area
Posts: 5,186
It might be too close to the heater....
OVT is offline  
post #5 of 16 (permalink) Old 08-30-2012, 05:05 PM Thread Starter
Planted Tank Enthusiast
 
shrimpzoo's Avatar
 
Join Date: Sep 2011
Location: Mississauga, Ontario, Canada
Posts: 774
Hmmmmm... light wasn't the problem then? I guess I should turn the lights on normally again.

I guess I'll move the heater a bit higher (it's only set at 72F though). But, do you guys think my moss will make a come back? or is it at the point of no return... ):

p.s: should I keep dosing seachem flourish generously and do a weekly water change of tap water? or just play the waiting game.
shrimpzoo is online now  
post #6 of 16 (permalink) Old 08-30-2012, 05:10 PM
Planted Tank Guru
 
Monster Fish's Avatar
 
Join Date: Mar 2011
Location: Queens, NY
Posts: 3,247
Seachem Flourish is just micros. Your moss needs some macros.

RAOK Club #77|The Fraternity of Dirt #112
Monster Fish is offline  
post #7 of 16 (permalink) Old 08-30-2012, 05:26 PM Thread Starter
Planted Tank Enthusiast
 
shrimpzoo's Avatar
 
Join Date: Sep 2011
Location: Mississauga, Ontario, Canada
Posts: 774
I guess I'll be using my tap water as a source of macros. Probably going to need to look for something that has macros in it to dose with my RO... since I'll be doing a very small mix of tap water with RO (so it probably won't be enough).

What do you guys recommend as a macro-nutrient supplement? Maybe this is why my java moss is turning yellow too...
shrimpzoo is online now  
post #8 of 16 (permalink) Old 08-30-2012, 05:46 PM
Planted Tank Guru
 
Monster Fish's Avatar
 
Join Date: Mar 2011
Location: Queens, NY
Posts: 3,247
You can either order dry-ferts or use the premixed stuff. Personally, I use Rootmedic in my low-tech tanks.

RAOK Club #77|The Fraternity of Dirt #112

Last edited by Monster Fish; 08-30-2012 at 05:47 PM. Reason: spelling error
Monster Fish is offline  
post #9 of 16 (permalink) Old 08-30-2012, 05:58 PM
Planted Tank Obsessed
 
sapphoqueen's Avatar
 
Join Date: Feb 2010
Location: Japan
Posts: 422
From too much light my java get only algae ))) LOL
yours looks burned from some chemicals or soo ...like melted or so
sapphoqueen is offline  
post #10 of 16 (permalink) Old 08-30-2012, 06:40 PM Thread Starter
Planted Tank Enthusiast
 
shrimpzoo's Avatar
 
Join Date: Sep 2011
Location: Mississauga, Ontario, Canada
Posts: 774
I guess it MIGHT be the heater... I don't put any chemicals in there ):
shrimpzoo is online now  
post #11 of 16 (permalink) Old 08-31-2012, 02:22 AM
Planted Tank Enthusiast
 
crice8's Avatar
 
Join Date: Aug 2012
Location: Texas
Posts: 642
are you using excel at all? it kills java like crazy
crice8 is offline  
post #12 of 16 (permalink) Old 08-31-2012, 02:27 AM
Algae Grower
 
Join Date: Apr 2012
Location: Indianapolis
Posts: 35
I use excel to kill off Blackbeard algae all the time and i have never melted java moss. Moss in general prefers a cooler water temperature I have 12 tanks full of every known available moss and it grows like weeds with the exception of my mini rose moss which is still acclimating to my tank.
skinyron is offline  
post #13 of 16 (permalink) Old 09-01-2012, 12:41 AM
plantedtank fiend
 
StrungOut's Avatar
 
Join Date: Nov 2004
Location: California
Posts: 1,353
Send a message via Yahoo to StrungOut
I think your lighting killed it off. Leaving your light on for 3 days straight could do that. Just give it time and proper rest, photoperiod back to the regular. If you keep trying to change your conditions trying to restore it (ie inconsistent water changes, big fert dosage), its more likely to die off trying to adapt back.

My Farm Tank
http://www.plantedtank.net/forums/sh...009&highlight=

"my arts so leonardo da vinci, picasso..."

demand skyrocketed, you all saw it.
StrungOut is offline  
post #14 of 16 (permalink) Old 09-01-2012, 12:52 AM
Wannabe Guru
 
Join Date: Mar 2012
Location: Tacoma Washington
Posts: 1,578
You know you can't just use pure RO water without re adding the minerals back, right?

Sent from my HTC Evo 4G

40B - Shrimp tank

~~~
jeremyTR is offline  
post #15 of 16 (permalink) Old 09-03-2012, 06:19 AM Thread Starter
Planted Tank Enthusiast
 
shrimpzoo's Avatar
 
Join Date: Sep 2011
Location: Mississauga, Ontario, Canada
Posts: 774
All I've done recently is:

- move the heater near the top of the tank
- add an API root tab (for macro nutrients)
- dose seachem flourish comprehensive (for micro nutrients)
- initiate weekly water changes
- and leave lights on for 10-12 hours a day

doesn't seem like the moss is doing any better... but I guess more time needs to pass.
shrimpzoo is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome