API First Layer Pire Laterite - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-31-2013, 09:28 PM Thread Starter
Algae Grower
PTrader: (0/0%)
Join Date: Jul 2012
Location: Mechanicsburg
Posts: 19
API First Layer Pire Laterite

I'm looking to add API's first layer Pure laterite to my planted 55gallon tank. I currently have just pea gravel substrate . Has any one ever uses this product to enhance their substrate ? What is you guys take on this product?
TinysTank is offline  
Sponsored Links
post #2 of 2 (permalink) Old 04-01-2013, 05:11 PM
Algae Grower
PTrader: (0/0%)
Join Date: Nov 2012
Location: central IA
Posts: 66
I bought a box of this to add to my gravel 20g long months ago...

Dusty, dusty, dusty. OMG. I rinsed this stuff for ages. It's still dusty. Your plants will accumulate dust on them. I didn't particularly care for the (red) color. I haven't noticed much increase in growth, but, every tank is different.

Putting First Layer Laterite in my tank is one of those things I did as a newb I wish I could take back. The price was right tho...but for the price, I'd much rather use FloraMax or something of the sort.
marko d is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome