Water still cloudy after adding eco-complete 3 days ago - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-20-2013, 10:58 PM Thread Starter
Algae Grower
 
Join Date: Aug 2012
Location: Massachusetts
Posts: 7
Water still cloudy after adding eco-complete 3 days ago

First of all, I'm new to the forum, so I am still getting used to everything.
Okay, so I added eco-complete gravel for planted tanks 3 days ago and the water is still cloudy. The water has cleared up a little, but it still has some cloudiness. http://www.flickr.com/photos/8417145...n/photostream/

Also, I've noticed some strange red and white pieces that are mixed with the black eco complete. I completely took out the previous gravel when adding the eco-complete so that could not have leaked into this. http://www.flickr.com/photos/8417145...n/photostream/

Did I get a bad batch? Are the irregularly colored gravel particles normal? Thanks
benappleboy is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-21-2013, 12:20 AM
Planted Tank Obsessed
 
Bubba Shrimp's Avatar
 
Join Date: May 2012
Location: Calgary, Alberta Canada
Posts: 349
Do a weekly water change ntill the water is clear.

So a guy walks into a Pet Store

Guy: "I have Algae on my drift wood!"

Pet Clerk: "Take two Plecos and call me next week."



EHEIM Classic 2213
Check out my blog
tsturgeonblog.wordpress.com/
Bubba Shrimp is offline  
post #3 of 8 (permalink) Old 02-21-2013, 12:27 AM
Planted Member
 
blue1delta's Avatar
 
Join Date: Jan 2013
Location: big swamp, NC
Posts: 269
I have eco complete and it looks identical. There are red and brown bits mixed in.
blue1delta is offline  
post #4 of 8 (permalink) Old 02-21-2013, 12:39 AM
Planted Tank Obsessed
 
Join Date: Sep 2012
Location: TX
Posts: 474
If this is a new tank the cloudiness may just be a bacteria bloo
- which is normal.
sarahspins is offline  
post #5 of 8 (permalink) Old 02-21-2013, 02:57 AM
Planted Member
 
Sharpchick's Avatar
 
Join Date: Feb 2013
Location: Mabelvale AR
Posts: 198
It took until the evening of the third day for my tank to settle after adding the Eco Complete.

The photo of your tank looks like mine did at that point.
Sharpchick is offline  
post #6 of 8 (permalink) Old 02-21-2013, 03:30 AM Thread Starter
Algae Grower
 
Join Date: Aug 2012
Location: Massachusetts
Posts: 7
Okay thanks everyone.
benappleboy is offline  
post #7 of 8 (permalink) Old 02-21-2013, 03:40 PM
Wannabe Guru
 
Join Date: Jan 2013
Location: Humarock - Boston MA
Posts: 1,400
I usually say toss some pantyhose over the filter intake, but those particles are so small prob wouldnt help much. If your at the store pick up the smallest bottle of seachem clarity if it hasnt changed, and want to speed it up. I used some for the hell of it 1-2 weeks ago for curiosity sake for eco, and flourite and cleared up in a couple hours.

I'm not into the image, but into the hobby...
CrypticLifeStyle is offline  
post #8 of 8 (permalink) Old 02-21-2013, 03:42 PM
Planted Member
 
tekkguy's Avatar
 
Join Date: Jan 2013
Location: Mesquite, TX
Posts: 164
If you left the scummy "bacteria water" in the Eco-Complete, that stuff takes days to clear out.
tekkguy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome