Flora Max - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-15-2013, 01:14 AM Thread Starter
Algae Grower
 
Join Date: Nov 2010
Location: ambler, PA
Posts: 100
Flora Max

I have never used substrate designed specifically for plants so I figured i would give it a try while setting up my new 36g. I bought a bag of Flora max, gave it a decent rinse and put it in the tank, then filled it. It's been about an hour with the filter running and its absolutely 1 huge dirt cloud. Is this expected? Did I not rinse enough? I am hoping it clears up overnight.
notsogreenthumb is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-15-2013, 01:28 AM
Algae Grower
 
Join Date: Nov 2012
Location: Missouri
Posts: 63
it does, but it clouds back up pretty easily when you disturb it.



but I'm happy with the way it looks, we'll both see if it grows plants well as I'm waiting for our local auction to get plants for the tank I put it in.
Contrl is offline  
post #3 of 9 (permalink) Old 01-15-2013, 02:01 AM Thread Starter
Algae Grower
 
Join Date: Nov 2010
Location: ambler, PA
Posts: 100
Quote:
Originally Posted by Contrl View Post
it does, but it clouds back up pretty easily when you disturb it.



but I'm happy with the way it looks, we'll both see if it grows plants well as I'm waiting for our local auction to get plants for the tank I put it in.
Hmm, I might try putting a layer of something more generic over top then if its gonna keep making the tank cloudy like this every time I vacuum it.
notsogreenthumb is offline  
post #4 of 9 (permalink) Old 01-15-2013, 12:51 PM
Planted Member
 
Borikuan's Avatar
 
Join Date: Jun 2012
Location: Lake Wales, FL
Posts: 241
You prolly did not rinse it enough. It should not make the tank cloudy when you kick up some while vaccuming. I disturb mine and it kicks uo detritus (waste) , but thats normal since i dont vaccum. But if yours is somewhat new, it prolly needs more rinsing.
Borikuan is offline  
post #5 of 9 (permalink) Old 01-15-2013, 03:49 PM
Algae Grower
 
Join Date: Jan 2013
Location: Baltimore, MD
Posts: 12
I had to wash this stuff for an hour before I felt ok putting it into the tank. I ran water over it in a 5 gal bucket and swirled it around intermittently, emptying and refilling the bucket.

Thank goodness for basement sinks!
mdmartin7 is offline  
post #6 of 9 (permalink) Old 01-15-2013, 04:58 PM
Planted Tank Enthusiast
 
zzrguy's Avatar
 
Join Date: Jul 2012
Location: LI NY
Posts: 555
I used it in my 5.5gl I did not rinse I laid a bag over it and poured the water over the bag.

I don't know where I'm going but I'm on my way.

29gal
zzrguy is offline  
post #7 of 9 (permalink) Old 01-16-2013, 12:20 AM
Wannabe Guru
 
Join Date: Jun 2011
Location: NJ
Posts: 1,458
Bunch o winers

Place a floss filter pouch over intake or add that extra HOB or canister(which everyone should have as a backup ICE). It should clear up in a day.
AirstoND is offline  
post #8 of 9 (permalink) Old 01-16-2013, 03:08 AM
Algae Grower
 
Join Date: Nov 2012
Location: Missouri
Posts: 63
it cleared up really nice in my case, but does kick up some dust when disturbed,,, the dust is really really heavy tho, and settles out in less than an hour or so...

So overall I'm happy, now to get planted and growing.....
Contrl is offline  
post #9 of 9 (permalink) Old 01-16-2013, 03:31 AM
Algae Grower
 
Join Date: Jan 2013
Location: Moreno Valley
Posts: 19
You can try capping the soil with a nice thin layer of sand
hecto33 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome