How bad is the effect of Maracyn to plants? - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-17-2004, 08:44 AM Thread Starter
Wannabe Guru
ninoboy's Avatar
Join Date: Jan 2004
Location: Las Vegas , Nevada
Posts: 1,261
I read many thread on BGA and somewhat understand about this type of algae/bacteria. I have some in my tank since last week but not as bad (actually very little compared to the tank pictures some of people's post here). I can easily vacuum it without and scrubbing or picking by hand. But most of them turned to brown. Are they dying? Do I need to treat with 1/2 dose of Maracyn? Also, I have a nice carpet of hairgrass in my tank that just turned nice green and covering the foreground nicely. Would Maracyn make it turn to brown??

I had problems with hair algae before and slight staghorn problems but they all are gone now without a trace :roll: . I don't know if this has anything to do with my BGA now.
ninoboy is offline  
Sponsored Links
post #2 of 3 (permalink) Old 04-17-2004, 09:43 AM
Planted Tank Enthusiast
2la's Avatar
Join Date: Aug 2002
Location: Portland, OR
Posts: 993
In the past I've only used it at half strength to no ill effect on my plants. I suspect that may be more conservative than necessary, but given that such a dose is completely effective against BGA, there's no real reason to use it at full strength.
2la is offline  
post #3 of 3 (permalink) Old 04-17-2004, 09:51 AM Thread Starter
Wannabe Guru
ninoboy's Avatar
Join Date: Jan 2004
Location: Las Vegas , Nevada
Posts: 1,261
Thanks 2la, I was worried on ruining my hard work on the hairgrass :lol:

I apologize, I think I didn't make it clear on my second question earlier. What I meant was I would follow the 1/2 dose of Maracyn if I really need to treat my tank. But I'm just not sure whether I need to treat it at all. Should I wait until it really blooms or are they dying in my tank already because they turned to brown color?

I'm really mad though. I just managed to get rid of all the hair and staghorn algae in my tank until no trace of them at all. It was so clear for a week and this BGA started to appear a few days ago. And just when I was gonna treat it, they turned to brown color. What the heck is going on :twisted:
ninoboy is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Here's a great how to lorax Riparium/Terrarium/Vivarium 3 06-09-2009 01:24 AM
terrestrial paludarium plants robitreef Riparium/Terrarium/Vivarium 8 02-19-2006 05:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome