Algae Tank - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-20-2004, 04:45 AM Thread Starter
Join Date: Mar 2004
Location: Mechanicsburg, PA
Posts: 4
Heres my problem, I have a 75e tank with 45lbs of laterite and 20lbs of gravel of the same size, 12 misc plants a Blue Ram and a Zebra Danio. I have about 3 different kinds of algae in there. I also run an Aqualife Aquaclear lamp with 2 65w bulbs. I run the lights for about 11 or 12 hours. Until I can afford a co2 setup what should I do to get rid of the algae?
z0phi3l is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-20-2004, 05:37 AM
Are these real?
Wasserpest's Avatar
Join Date: Jun 2003
Location: Monterey, CA
Posts: 15,385
Hi and welcome to the Planted Tank, the answer to all your algae problems!

This is what I would do:

Plant lots and lots of stem plants.

Test NO3 and PO4. Should be around 5 ppm and 0.5 ppm, respectively. Report back with actual levels

Drink two 3 liter bottles of soda :aah: and convert them to CO2 producing machines.

Questions: How long has the tank been set up? Do you add any fertilizer already? Are the plants growing or stagnant?
Wasserpest is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hair algae and brush algae fedge Algae 2 06-01-2004 08:08 PM
Plants have grown nicely crazy! So have algae :( Help! FrozenAssassin Algae 2 02-03-2004 07:30 PM
Hair Algae Case Study- Long ken6217 General Planted Tank Discussion 4 01-18-2004 11:17 PM
Blue algae in an established tank... HawkEye_Pierce Algae 20 12-05-2003 11:27 PM
New tank...fertilizer questions and problems ^iMp^ General Planted Tank Discussion 5 11-23-2003 06:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome