Help ID & get rid of algae - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-02-2013, 03:33 AM Thread Starter
Planted Member
Join Date: Jan 2013
Location: USA
Posts: 259
Help ID & get rid of algae

Can anyone I'd the brown algae in the photo? It is plaguing my tank and I want to be rid of it.

I rescaped a few weeks ago, completely draining my tank and switching out my gravel to eco complete. Before the rescape I had some green hair algae on some plants, but this brown stuff is way worse.
40b tank
Finnex fugeray on 8hr a day.
Does ei but on a reduced scale for now
Problem started before co2 but I now have a co2 system that I start 1 hr before lights on and stop 1 hr before lights off.
Shawn123 is offline  
Sponsored Links
post #2 of 7 (permalink) Old 10-02-2013, 05:57 AM
Planted Tank Guru
ua hua's Avatar
Join Date: Oct 2009
Location: Nebraska
Posts: 2,458
Looks to be Rhizoclonium to me. Check out the stickies on the top of the Algae subforum.

All matter is merely energy condensed to a slow vibration, we are all one consciousness experiencing itself subjectively, there is no such thing as death life is only a dream which is an imagination of ourselves. Bill Hicks
ua hua's 90 gal. high tech
ua hua's 5,000 gal. water garden
ua hua is offline  
post #3 of 7 (permalink) Old 10-02-2013, 01:48 PM Thread Starter
Planted Member
Join Date: Jan 2013
Location: USA
Posts: 259
Ok it does look like the pic in the first link, but the description of why it occurs doesn't make sense. It says low flow, lack of maintenance, low co2. I do 50% wc every week, pressurized co2 where drop checker is lime green by end of day, and the algae grows right in the path of my power head and actually waves in the current.

Could it still be rhizoclonium and what would you suggest to get rid of it. I have been manually removing it a few times a week.
Shawn123 is offline  
post #4 of 7 (permalink) Old 10-02-2013, 03:39 PM
Planted Member
Shimagoma's Avatar
Join Date: May 2012
Location: Baltimore
Posts: 165
Send a message via AIM to Shimagoma Send a message via Skype™ to Shimagoma
It looks like there might be some staghorn mixed in there as well? But it looks like Rhizoclonium to me too.
First things first I would reduce the lighting!
Shimagoma is offline  
post #5 of 7 (permalink) Old 10-02-2013, 03:57 PM
Planted Tank Enthusiast
jfynyson's Avatar
Join Date: Apr 2013
Location: NC
Posts: 838
Read this thread to kill the algae then find your tank's "balance" to mitgate new algae growth. To find that balance please provide everyone with your tank parameters.

The "One-Two Punch" Whole Tank Algae Treatment
jfynyson is offline  
post #6 of 7 (permalink) Old 10-02-2013, 06:53 PM
Planted Tank Enthusiast
Join Date: Sep 2012
Location: Sacramento, CA
Posts: 765
Clean that up as best you can manually. Takes a while but do it. If you got more plants add em. Rhizo is pretty tough, but blackout will hurt it back. I got rid of it recently using blackout + manual cleanup. also, possible get a powerhead to add more current, possibly debris is getting lodged in the rhizo and settling on leaves. A bit of current will help blow it off.
puopg is offline  
post #7 of 7 (permalink) Old 10-03-2013, 04:45 AM Thread Starter
Planted Member
Join Date: Jan 2013
Location: USA
Posts: 259
Thanks for the replies.
I will try to get params tomorrow if I can.
Today I noticed a good chunk was gone off my driftwood. I wonder if my amanos started eating it or what made it go away.(Do amonos eat this?) I added 12 amanos a few weeks ago. 2 for sure died the day of/after adding. I never see the other ones but have seen a few molten shells lately so some are for sure still alive but i have no idea where they hide. Also, I did clean my cannister a few days ago so maybe that is helping?

I am upping my dosage of excel from every other day to every day.

Have some plants on the way so plant mass will be increased soon.

Hopefully can test and post params tomorrow

Thanks for the replies so far

I would like to avoid 1 2 punch unless the situation keeps getting worse. I just want to find the right balance.
Shawn123 is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome