Flame Algae - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 09-15-2013, 04:08 AM Thread Starter
Planted Tank Obsessed
Nightspell's Avatar
Join Date: May 2013
Location: Pacific Northwest US
Posts: 304
Flame Algae

RIGHT. So... Behold my Flame Moss! It's in there somewhere, I swear. Can someone please ID this algae? I know thread algae looks similar to another type bit I can't tell the difference. This is the only occurrence of it in my tank, it's localized entirely in my "flame moss" garden here. Any way to salvage it, or should I just scrap the whole thing? Excel has been ineffective and I think I've pretty well maxed out my CO2. My other mosses are fine... Odd. Appreciate any insight!
Nightspell is offline  
Sponsored Links
post #2 of 9 (permalink) Old 09-15-2013, 04:43 AM
Planted Tank Enthusiast
stealthypotatoes's Avatar
Join Date: Feb 2013
Location: Queens, New York
Posts: 851
Hair algae maybe?
Get some SAEs
I grow some in a breeder box just to beef up my saes.
I feed them the algae by hand. Thats how friendly they are.
stealthypotatoes is offline  
post #3 of 9 (permalink) Old 09-15-2013, 04:47 AM
Planted Tank Enthusiast
Warlock's Avatar
Join Date: Feb 2012
Location: Austin
Posts: 884
i just bought some SAE.. i have a couple of tanks that need some work.. hope this works
Warlock is offline  
post #4 of 9 (permalink) Old 09-15-2013, 04:53 AM
Planted Tank Enthusiast
Join Date: Jun 2013
Location: Gloucester, Virginia
Posts: 513
thread algae/hair algae,, i had the same problem with my flame moss.... in the end i decided to remove it manually. i removed about 90% of it and literally 2 days later it was all back. when i decided to remove it manually again, i took a close look at the moss and i found the underlying problem that was causing the algae to grow just in that one area. under the healthy algae filled moss was a crap load of dead moss.(i assume it was feeding the algae) all in all i lost about half my moss by pulling out anything that was brown but now the algae is minimal to almost none
flukekiller is offline  
post #5 of 9 (permalink) Old 09-23-2013, 01:37 AM
Planted Tank Enthusiast
CPDzeke's Avatar
Join Date: Jan 2013
Location: Minnesota
Posts: 960
Spirogyra... It will try to eat your tank.

ADA Gentleman #1
Treeless Mountain V3
CPDzeke is offline  
post #6 of 9 (permalink) Old 09-23-2013, 07:13 AM
Algae Grower
Join Date: Aug 2013
Location: Australia
Posts: 62
what is the best way to get rid of the Spirogyra? I am 99% I have this starting in my tank!!
JKS is offline  
post #7 of 9 (permalink) Old 09-23-2013, 01:09 PM
Planted Tank Enthusiast
CPDzeke's Avatar
Join Date: Jan 2013
Location: Minnesota
Posts: 960
Algaefix is the only way I know of, in addition to blackouts.

ADA Gentleman #1
Treeless Mountain V3
CPDzeke is offline  
post #8 of 9 (permalink) Old 09-24-2013, 04:50 AM
Planted Tank Guru
gordonrichards's Avatar
Join Date: Jun 2009
Location: Huntington Station, NY
Posts: 4,637
Send a message via Yahoo to gordonrichards
Flag Fish. You will be amazed how much they eat!

gordonrichards is online now  
post #9 of 9 (permalink) Old 09-25-2013, 08:16 PM
Planted Tank Obsessed
Join Date: Apr 2012
Location: Los Angeles, CA
Posts: 403
I had something like this growing in my flame moss too. I removed most of it by hand, and then the baby trumpet snails moved in. They spent a few weeks covering the moss in packs, then moved on. Very little algae now...
TwoTacoCombo is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome