Question about treating algae - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-02-2013, 11:12 PM Thread Starter
Wannabe Guru
 
tattooedfool83's Avatar
 
Join Date: Mar 2013
Location: North Providence, RI
Posts: 1,866
Question about treating algae

So ive had these micro swords for a couple months now. They have always had algae but it got to the point where i just pulled them today, but id hate to just throw them out. So i have them all sitting in a 5 gallon bucket.

Can i dip these? I dont plan on putting them back in my tank, maybe tray emersed with these in some tupperware? Is that possible with micro sword? Ill post some pictures and if need be then ill just toss them but id hate to just be done with them. There is also a amazon sword floating in one pic, no algae on this and i actually cut it off the mother and planted it by itself maybe 2 months ago. Its grown so much in that time.
Attached Thumbnails
Click image for larger version

Name:	20130602_185700.jpg
Views:	32
Size:	144.6 KB
ID:	152114  

Click image for larger version

Name:	20130602_185715.jpg
Views:	45
Size:	110.9 KB
ID:	152146  

Click image for larger version

Name:	20130602_185723.jpg
Views:	38
Size:	129.9 KB
ID:	152154  

Click image for larger version

Name:	20130602_185741.jpg
Views:	28
Size:	90.8 KB
ID:	152162  

Click image for larger version

Name:	20130602_185746.jpg
Views:	92
Size:	110.8 KB
ID:	152170  

tattooedfool83 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-02-2013, 11:21 PM
Planted Tank Enthusiast
 
jfynyson's Avatar
 
Join Date: Apr 2013
Location: NC
Posts: 841
I would take a about 1/4 to 1/2 of what you have there to try this. Fully submerge in H2O2 (hydrogen peroxide....$0.88 at Walmart). Soak 3-5 minutes max then try and brush them out with an old tooth brush. Then put them back in the tank. This has worked well for me on other plants like swords, crypts, and nanas. I've not seen anyone on here have any issues with H2O2 on grasses.

Best of luck !
jfynyson is offline  
post #3 of 5 (permalink) Old 06-02-2013, 11:25 PM
Planted Member
 
thinBear's Avatar
 
Join Date: Dec 2011
Location: Bay Area, CA
Posts: 278
I think if you tray emersed them, the algae will die off eventually;
or physically remove algae with magic eraser, the one not pre-soaked with chemical Magic Algae Eraser

you cannot get rid of the algae spores, they will come back soon or later if the parameter of the tank is not right. Could be CO2, nutrient imbal, lighting, flow...etc
thinBear is offline  
post #4 of 5 (permalink) Old 06-03-2013, 12:19 AM Thread Starter
Wannabe Guru
 
tattooedfool83's Avatar
 
Join Date: Mar 2013
Location: North Providence, RI
Posts: 1,866
Im fairly new to the planted tank hobby. THese came out of a 75 gallon, its just a mess right now. Im not happy with it. Ive happy better luck with my smaller tanks. Funny enough right? Its said that its harder to keep tanks in check that are smaller water volume.

Really im just looking to try something else with this stuff, should i plant it in soil then and wrap the container?
tattooedfool83 is offline  
post #5 of 5 (permalink) Old 06-20-2013, 08:33 PM Thread Starter
Wannabe Guru
 
tattooedfool83's Avatar
 
Join Date: Mar 2013
Location: North Providence, RI
Posts: 1,866
So I ended up planting these in soil and submerging the soil in water and leaving plastic wrap over them. They are sending out runners like crazy

Sent from my SAMSUNG-SGH-I777 using Tapatalk 4 Beta

Last edited by tattooedfool83; 06-18-2014 at 11:39 AM.
tattooedfool83 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome