Treating algae on slower growing plants - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 16 (permalink) Old 06-19-2013, 06:20 AM
Algae Grower
PTrader: (8/100%)
Join Date: Jun 2013
Location: Los Angeles
Posts: 25
Hello everyone...this is my very first post... I had a very bad issue with green spot algae on a rather large anubia and java fern (too much lighting).... Being impatient, I remove these effective plants from the tank and did a two minute dip in bleach heavily diluted in water (avoiding wetting the rhizome)...almost instant results...and no apparent negative effectives on the thick leaved anubia.... Just my two cents....since placing in a dimmer area, no problems at all since.... By the way, wonderful website!!!
Bongox3 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome