Red Algae ?? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 04-02-2013, 05:54 PM Thread Starter
Planted Tank Enthusiast
 
Join Date: Feb 2012
Location: USA
Posts: 692
Cool Red Algae ??

Hello,

Does anyone ever see or know about the Red Algae, it was on my filter tube last night, it look a bit similar to the black algae, but this is RED color. I have to clean it from hot water in order to make it all go away from the filter tube.

10 of my neon tetras died in 1 night and then I changed the 50% water, after next day 1 long finned albino died, and 1 female angel fied in the last 1-2 days.

Below is something similar like I found on google.


Last edited by Master503; 04-02-2013 at 10:27 PM. Reason: .
Master503 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 04-02-2013, 06:46 PM
Planted Tank Guru
 
NWA-Planted's Avatar
 
Join Date: Aug 2011
Location: Bentonville, AR
Posts: 3,399
Re: Red Algae ??

You have any photos of it in your tank?

Sent from my SCH-I535 using Tapatalk 2

Sump Pimp #8
RAOK Clubber #28
NWA-Planted is offline  
post #3 of 9 (permalink) Old 04-02-2013, 07:34 PM Thread Starter
Planted Tank Enthusiast
 
Join Date: Feb 2012
Location: USA
Posts: 692
Actually the red algae now is gone from my tank .. it was only on the filter tube .. don't see anywhere else ...
Master503 is offline  
post #4 of 9 (permalink) Old 04-02-2013, 08:13 PM
Planted Tank Guru
 
NWA-Planted's Avatar
 
Join Date: Aug 2011
Location: Bentonville, AR
Posts: 3,399
Re: Red Algae ??

Very odd, so do you think the fish died due to something with this algae?

Sent from my SCH-I535 using Tapatalk 2

Sump Pimp #8
RAOK Clubber #28
NWA-Planted is offline  
post #5 of 9 (permalink) Old 04-02-2013, 10:24 PM Thread Starter
Planted Tank Enthusiast
 
Join Date: Feb 2012
Location: USA
Posts: 692
My tank run for 5-6 years and I have never had any problems in the past, but this is just happen like 2-3 days ago and the red Algae I just saw last night on the tube of filter. Would this has some kind connection?
Master503 is offline  
post #6 of 9 (permalink) Old 04-02-2013, 11:34 PM
Planted Tank Guru
 
NWA-Planted's Avatar
 
Join Date: Aug 2011
Location: Bentonville, AR
Posts: 3,399
Re: Red Algae ??

No algae expert but normally I wouldn't think any algae would cause a die off like that :-/

Thats really bizarre, I suppose it's possible but I don't have an answer for you

Sent from my SCH-I535 using Tapatalk 2

Sump Pimp #8
RAOK Clubber #28
NWA-Planted is offline  
post #7 of 9 (permalink) Old 04-02-2013, 11:45 PM Thread Starter
Planted Tank Enthusiast
 
Join Date: Feb 2012
Location: USA
Posts: 692
I will take the water sample to LFS to let them test it. Will see how that come out.
Master503 is offline  
post #8 of 9 (permalink) Old 04-04-2013, 07:09 PM Thread Starter
Planted Tank Enthusiast
 
Join Date: Feb 2012
Location: USA
Posts: 692
Oh man! some of my fishes are died more .. this is getting out of control .. any idea what should I do? take all the fish put in different tank?
Master503 is offline  
post #9 of 9 (permalink) Old 04-04-2013, 08:53 PM
Planted Tank Enthusiast
 
gSTiTcH's Avatar
 
Join Date: Feb 2013
Location: Jacksonville, Florida
Posts: 838
I would definitely transfer to a different tank, at least until you can ID the cause.
gSTiTcH is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome