What is going wrong here? Overdue update! - Page 2 - The Planted Tank Forum
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 16 (permalink) Old 07-30-2013, 05:13 PM
Algae Grower
 
Dannyul's Avatar
 
Join Date: Jun 2013
Location: Cheshire, UK
Posts: 137
Your tank looks well - keep it up!

Best of luck,
Dan

Dan
Planted Tank Enthusiast


80L Opti White heavily planted open-top tank: JBL CristalProfi 1501e containing a range of filter media; EI dosing; pressurised CO2 with Lily Pipes and Surface Skimmer; Finnex Planted+ LED Light. Neons, Embers, Pygmy Corys, Amano's and Oto's ..and I'm in love with it.

If I have helped you or require further information / advice, then please do not hesitate to drop me a message!
Dannyul is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome