SpiroGyra Algae caused by ammonia spike in fishless cycle ? - The Planted Tank Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-21-2013, 03:21 PM Thread Starter
Planted Member
 
Join Date: Nov 2012
Location: Brooklyn NYC
Posts: 197
SpiroGyra Algae caused by ammonia spike in fishless cycle ?

SpiroGyra Algae is starting to pop up. All the information I can find says it is induced by an ammonia spike. How could I avoid that if I am still cycling my aquarium ??

A bit frustrated. It amazes me how ridiculously fast algae can pop up and grow. Literally in one day a few strands, and the next day when I wake up at least triple the amount.

I just did a 90 percent water change
Manually removed as much as possible.
Overdosed excel by 3x.
Added a power-head which I have avoided because I honestly feel its probably too much flow. (any advise here ?)
Replaced my ceramic disk with a new one hopefully for better diffusion of co2

If you have experience with this algae and can share some advise , I would greatly appreciate that. Thank you ! <33
jonathan is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-21-2013, 04:06 PM
Surrounded by Blyxa
 
TexasCichlid's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 1,510
Excel won't even phase spiro. Once spiro is established, it likes everything normal plants do. More flow and CO2? Great for it. Get some algaefix, it will knock it out. For it to pop up so quickly and spread so quickly during a cycle, sounds like it hiked in on something and/or you didn't have enough plantmass for the amount of light you have.
TexasCichlid is offline  
post #3 of 5 (permalink) Old 01-21-2013, 04:15 PM Thread Starter
Planted Member
 
Join Date: Nov 2012
Location: Brooklyn NYC
Posts: 197
Quote:
Originally Posted by TexasCichlid View Post
Excel won't even phase spiro. Once spiro is established, it likes everything normal plants do. More flow and CO2? Great for it. Get some algaefix, it will knock it out. For it to pop up so quickly and spread so quickly during a cycle, sounds like it hiked in on something and/or you didn't have enough plantmass for the amount of light you have.

I dont have enough plant mass. Thats probably one thing. My foot print is mostly covered but at this stage the plants are very short and carpet has not really begun to fill in. You know ? Mostly new. Lighting is teetering mid/high.
jonathan is offline  
post #4 of 5 (permalink) Old 01-21-2013, 07:29 PM
Surrounded by Blyxa
 
TexasCichlid's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 1,510
Drop your photoperiod down to 8 hours or less, keep your CO2 high and dose some Algaefix then.
TexasCichlid is offline  
post #5 of 5 (permalink) Old 01-24-2013, 06:37 PM Thread Starter
Planted Member
 
Join Date: Nov 2012
Location: Brooklyn NYC
Posts: 197
Quote:
Originally Posted by TexasCichlid View Post
Excel won't even phase spiro.
Sadly it destroyed my HM. I've never seen this plant on the sensitive list so I dosed. I see its not completely dead and will return, but it looks absolutely ugly now. I hate excel!

spiro is still alive but has slowed down to a crawl. 1 - 2 strands per day. Photoperiod reduced to 5 hours and 50 % water changes everyday.
jonathan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome