Help me identify this algae, please! - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-18-2012, 01:29 AM Thread Starter
Algae Grower
Join Date: Jun 2011
Location: US
Posts: 139
Help me identify this algae, please!

How do I kill it!

Sent from my SCH-I605 using Tapatalk 2
bat_billy is offline  
Sponsored Links
post #2 of 4 (permalink) Old 12-18-2012, 03:47 AM
Planted Tank Enthusiast
auban's Avatar
Join Date: Jun 2012
Location: North Carolina
Posts: 592
looks like hair algae. easiest way to get rid of it without adding something that eats it is to take the plant out and dip it in a 1/5 solution of flourish excel for 30 seconds, or you can nuke it in the tank with targeted applications.

a total blackout could kill it, but it takes a while to die, so you may end up killing your plants. reducing to photoperiod to no more than three hours on with an hour or two of darkness before turning them back on can slow it down in the mean time. its not an easy algae to get rid of, but it isnt impossible.
auban is offline  
post #3 of 4 (permalink) Old 12-18-2012, 05:31 AM
Honeycomb Master
Centromochlus's Avatar
Join Date: May 2008
Location: Phoenix/Flagstaff, AZ
Posts: 6,726
Yup, probably hair algae. I would personally recommend picking up a bottle of Flourish Excel and a syringe, and using the "target" method. Turn off your filter and squirt the excel right on top of where the algae is (a small amount goes a long way). Let it sit for about 10 minutes or so, then turn your filter back on. You should notice that the algae turns red or white after 24-48 hours, which is a good sign that it is on it's way out. If you don't notice any color change within a couple of days, repeat the treatment.

Centromochlus is offline  
post #4 of 4 (permalink) Old 12-18-2012, 05:51 AM
Algae Grower
TheKribKeeper's Avatar
Join Date: Oct 2012
Location: California
Posts: 130
Looks to me like it is staghorn algae does it branch out? In the picture it kind of looks like it branches but hard to tell. If not its hair algae like the other two posters said.
TheKribKeeper is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome