Whitish fuzzy mold in DSM - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-17-2012, 11:35 PM Thread Starter
Algae Grower
Join Date: Sep 2012
Location: Emeryville, CA
Posts: 42
Whitish fuzzy mold in DSM

I went up to NY for the weekend like normal and when I got back, my driftwood had this stuff in a few spots. Also covering more of the driftwood is the greenish stuff. Any ideas of what it could be or suggestions? Should I spray it with a dilution of Excel?

player 2 is online now  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome