MY tank is turning green...not in a good way - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-16-2012, 03:48 AM Thread Starter
Join Date: Sep 2012
Location: Long Island N.Y.
Posts: 3
MY tank is turning green...not in a good way

Iv'e had a planted tank for about a year and have never had a problem....seems to be famous last words on this forum. About three months ago I got green hair algae and decided to start EI dry dosing. This worked AMAZING for about 2 months, now my tank has literally been cut down to nothing. I am out of ideas and frankly my eyes hurt from reading from reading for hours at a time for the past few months. If you have any ideas, please help me out.

45 Gallon Tall Planted Tank
pressurized CO2 at 30ppm according to my drop checker
Koralia nano 240
Dry EI dosing
T5HO x 2 6700K
5 young Angels bred by yours truly
Star Grass
Rotala Wallichii
Amazon swords
Alternanthera reineckii
Carolina Cabomba

GH - 0
KH - 0
PH - 0
Nitrite - 0
Nitrate - 5.0ppm

Pictures of the damage

stazitto25 is offline  
Sponsored Links
post #2 of 5 (permalink) Old 09-16-2012, 10:03 AM
Planted Tank Obsessed
cradleoffilthfan's Avatar
Join Date: Jan 2009
Location: Eureka, California
Posts: 323
a little cloudy is your problem? What is your ammonia levels?
cradleoffilthfan is offline  
post #3 of 5 (permalink) Old 09-16-2012, 12:30 PM Thread Starter
Join Date: Sep 2012
Location: Long Island N.Y.
Posts: 3
I think the cloudiness is a combination of my phone camera and the intense amount of algae i scraped off of the glass before I took these pictures. I just tested my ammonia and it is .50. Today is the day I do my 50% water change for the EI dosing.

If you look at the leaves on the swords and the Alternanthera, you can notice the thick algae that is taking over everything. I can scrape it off easy, but it grows back in about 2 days. It is all in my gravel, on my plants, and glass.

Any idea on what it might be?
stazitto25 is offline  
post #4 of 5 (permalink) Old 09-16-2012, 04:15 PM
Planted Tank Guru
Kathyy's Avatar
Join Date: Feb 2010
Location: Newbury Park, CA
Posts: 3,953
Originally Posted by stazitto25 View Post
GH - 0
KH - 0
PH - 0
Nitrite - 0
Nitrate - 5.0ppm
^This could be your problem. EI doesn't cover it all. The calcium, magnesium and carbonate in GH and KH are essential to good plant health as well.

I have been tricked into thinking glass algae was green water too!

How healthy is the biological filter? If you have any ammonia in an established tank something bad is going on. Checked everywhere for dead fish? Cleaned out dead leaves? Filter output okay? My tank has been rock solid stable since I put a lot more biological filter media in the sump but I am still knocking on wood that GW doesn't become an issue ever again.
Kathyy is offline  
post #5 of 5 (permalink) Old 09-16-2012, 11:42 PM Thread Starter
Join Date: Sep 2012
Location: Long Island N.Y.
Posts: 3
Hey Kathyy,

I ripped apart the tank today and took out all of the dead plants so I am hoping that will help with the ammonia as this tank is a few years established. I also got a GH booster to get the GH up. I honestly never even thought of looking there as GH and KH have never been a problem for me. About half an hour later everything started pearling. So it seems this may have been the problem all along. I have not done research on raising KH or how to, but I will look into this. Thank you for the advice!
stazitto25 is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome