Is this algae - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-13-2012, 04:38 PM Thread Starter
Algae Grower
Join Date: Aug 2012
Location: NJ
Posts: 64
Is this algae

My guess is if it is algae its staghorn but I'll the pics of staghorn look threadlike and this stuff has a flat surface which is weird to me. Also it only seems to grow in moss so I didn't notice it until I really looked. I recently set up high lighting with co2 on this tank.

Sent from my Galaxy Nexus using Tapatalk 2
ctls is offline  
Sponsored Links
post #2 of 3 (permalink) Old 09-13-2012, 05:08 PM
Planted Tank Guru
Join Date: Jan 2010
Location: Contra Costa CA
Posts: 10,489
Kinda looks more like Riccia, or Crystalwort, but the blades look a bit too thin. Anyway, google some pictures and see it that is what it is.
Diana is online now  
post #3 of 3 (permalink) Old 09-13-2012, 05:59 PM Thread Starter
Algae Grower
Join Date: Aug 2012
Location: NJ
Posts: 64
yes that's definately what it is thanks
ctls is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome