Accidentally got some algae in my "dry" can I get rid of it? - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-12-2012, 09:32 PM Thread Starter
Planted Tank Guru
HybridHerp's Avatar
Join Date: May 2012
Location: New York
Posts: 3,882
Accidentally got some algae in my "dry" can I get rid of it?

So, while I was away I had my neighbor mist my 5 gallon dry start on HC
now, the plant has been growing and doing okay but when I came back I noticed that there was more water in the dry start than I would have liked, and that this had an algae film developing and a relatively good amount of algae in general.

The steps I have taken so far have been to add more water to the tank so that I could scoop some algae out, then drain it back down so that there are no submersed spots in the dry start.

My 75 gallon High Tech Tank:
My 10 gallon High Tech Tank:
My 5.5 gallon nano College Dorm Tank:
Mom's Spec V:
HybridHerp is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome