Algae Help Needed! - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-13-2011, 04:32 AM Thread Starter
Newbie
 
Join Date: Dec 2011
Location: Houston, TX
Posts: 2
Algae Help Needed!

Hey Y'all, I am in need of some really big help. I've been trying to start a planted aquarium for some time now and one problem leads to another and then to another and so on and so forth. My most cumbersome challenge has been this fuzzy algae that grows on the substrate, plants and the diffuser!

Currently, the pH is at 6.5 and KH at 5. I do routine water changes and am just lost... please help!

Here are some pictures of whats going on:
https://picasaweb.google.com/lrondue...eat=directlink

Trying to get a grasp of things,

LR
minipapio is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-25-2011, 04:23 PM
Planted Member
 
Join Date: Feb 2009
Location: Olympia, WA
Posts: 295
Welcome to TPT!

Holy smokes! That's some serious algae! Your pH and KH are fairly insignificant. What matters is Light and CO2. I'm pretty confident from that photo that you've got too much light. Fix the light then hire yourself a troup of algae eaters to clean up the mess. Shrimp and ottos should help.

There are various other things that cold be contributing to your situation. Post all the details of your tank (equipment, water additives, substrate, flora, fauna, temperature, and anything else you can think of) then folks here can help you figure out ways to improve.

Good luck!
ghotifish is offline  
post #3 of 4 (permalink) Old 12-25-2011, 06:38 PM
Planted Tank Enthusiast
 
Naekuh's Avatar
 
Join Date: Oct 2011
Location: Los Angeles
Posts: 884
do you have fish inside?

For now, i would nuke your tank with H2O2 without the fish in it..

like seriously get a big bottle and just DUMP it in.

But you would probably kill whatever u had inside the tank.
Naekuh is offline  
post #4 of 4 (permalink) Old 12-25-2011, 08:47 PM
Planted Tank Guru
 
Kathyy's Avatar
 
Join Date: Feb 2010
Location: Newbury Park, CA
Posts: 4,182
Tell us more about your set up. Diffuser sounds like you are using CO2 of some sort?? Light? Filtration, circulation, size and age of tank setup, fertilizing, substrate, flora and fauna?
Kathyy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome