Please help identify :/ - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-22-2011, 03:40 AM Thread Starter
Algae Grower
Join Date: Nov 2011
Location: Canada
Posts: 20
Please help identify :/

Hey guys i'm new in this forum and new to this hobby! So what up everyone?

Anyways, got this weird white stuff growing near the roots of my crypt parva and on some of leaves as well not sure if its some kind of algae or some fungus or something so please help me out. There's more appearing on my other crypt parva as well but its not coming out clear so I didn't upload that one.

I know the picture isn't that clear I used my phone to take the picture, I can try to take some more later if needed.

Any thoughts?
Attached Thumbnails
Click image for larger version

Name:	IMG_20111121_191921.jpg
Views:	49
Size:	148.2 KB
ID:	37860  

SexMachineGuns is offline  
Sponsored Links
post #2 of 5 (permalink) Old 11-22-2011, 03:56 AM
Planted Tank Guru
Monster Fish's Avatar
Join Date: Mar 2011
Location: Queens, NY
Posts: 3,208
It's kind of hard to tell but Im guessing it's crypt melt. Though if the plant was damaged during transit, I believe fungus would grow from damaged areas, but that is just a wild guess. Clearer pics would be nice.

Also are you by any chance a Sex Machineguns fan?

RAOK Club #77|The Fraternity of Dirt #112
Monster Fish is offline  
post #3 of 5 (permalink) Old 11-22-2011, 04:06 AM
Planted Tank Guru
msjinkzd's Avatar
Join Date: May 2007
Location: mount wolf, pa
Posts: 3,870
Send a message via AIM to msjinkzd

<sorry that was not very helpful>
msjinkzd is online now  
post #4 of 5 (permalink) Old 11-22-2011, 04:28 AM Thread Starter
Algae Grower
Join Date: Nov 2011
Location: Canada
Posts: 20
If that is Crypt Melt what should I do about it? Just leave it or try to remove it or the plant?

I do like sex machineguns though I don't listen to them that much... sick guitarists! I am more a fan of their band name tho probably hahaha
SexMachineGuns is offline  
post #5 of 5 (permalink) Old 11-22-2011, 08:33 AM
Planted Tank Obsessed
Join Date: May 2011
Location: Edmonton AB Canada
Posts: 353
Looks like some kinda fungus since it's growing away from the stem... leaves look fine, plant color looks fine, I don't think it would be melting.

Got any shrimps? My RCS and amanos eat the hell out of all the fungus I get like that growing in my tanks
tbarabash is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome