Trouble w/ Diatom and GSA - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-03-2011, 12:42 AM Thread Starter
Algae Grower
Join Date: Feb 2010
Location: maplewood
Posts: 37
Trouble w/ Diatom and GSA

I am kinda stuck, I have been battling brown/diatom algae and GSA for a few weeks now and nothing seems to be affecting it. The tank's been running for 8 months now.
My plants are growing at a steady pace but the broad leaved plants like ludwigia are stunted, the older leaves have shrunk and the new shoots are significantly smaller. Older leaves are covered with brown and GSA. My red plants (L. Red, R. Butterfly) are more like brownish red. Some of the shoots are even greenish looking. My glosso is like 3" tall (IDK what's wrong with it here, thought high light makes it grow low).

Despite the comment on the glosso, I think that my light maybe too much for the rest of the plants? I think it maybe the cause of the algae, but I am not sure of anything now. How do I battle that and what should I change?

My tank is a 29 gallon standard.
150 watt PFO Metal Halide
Oil-Dri substrate w/ playsand
Aquatop CF 330 canister filter
Pressurized CO2, CO2 indicator is at yellowish green.

Parameters as of now.
I dose PPS majority of the time, I have been playing with the fertz to fluctuate the nitrate and phosphate levels to see if it will have effect on the algae but nothing so far.
jocky is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-03-2011, 01:04 AM
Planted Tank Guru
Kathyy's Avatar
Join Date: Feb 2010
Location: Newbury Park, CA
Posts: 3,949
My 150 watt MHs are about 37" above the substrate and the tank is covered with cloudy acrylic. I will put window screen to shade if I remove lots of plants or allow floaters to build up to dim the light. Yes, you have more light than needed! Try raising it and shading the tank quite a bit and see if things improve in about a week.
Kathyy is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome