Blue Green Algae - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-25-2011, 02:27 AM Thread Starter
Algae Grower
emboli's Avatar
Join Date: Jul 2011
Location: australia
Posts: 131
Blue Green Algae

I believe i have this algae growing in my tank
however the solution according to this chart
is to increase my nitrates.
However I deliberately have reduced my nitrates for my crystal shrimp.

Is there any other way of killing this algae?

I dun want to have to use chemicals. I am thinking of getting a couple of ottos today
My 15gallon planted aquarium blog
emboli is offline  
Sponsored Links
post #2 of 4 (permalink) Old 08-25-2011, 02:55 AM
Algae Grower
Join Date: May 2011
Location: Malaysia
Posts: 11
i dun think otto will chew BGA, they are not algae but bacteria..
soonsing86 is offline  
post #3 of 4 (permalink) Old 08-25-2011, 03:15 AM
Planted Tank Guru
jreich's Avatar
Join Date: Feb 2009
Location: philadelphia
Posts: 2,940
noting eats bga, i had to treat with an antibiotic. its not harsh on the BB, or flora/fauna. i dont remember the name of it tho. (maybe enthromyiacin (sp?))
jreich is offline  
post #4 of 4 (permalink) Old 08-25-2011, 07:48 PM
Planted Tank Guru
kamikazi's Avatar
Join Date: Sep 2010
Location: Lincolnton, NC
Posts: 2,245
kamikazi is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome