My first planted tank- 3g eclipse (**PICS**) - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 16 (permalink) Old 12-11-2008, 06:31 AM Thread Starter
Planted Member
hilikus16's Avatar
Join Date: Nov 2008
Location: georgia
Posts: 159
update: 12/10/08

it's been one week since i planted the marselia and im already noticing some good growth. everything else is growing pretty steadily too, especially the crypts. not much else has changed.

the glare on the front of this tank is just killing me. that and i keep scratching it by accident. this is why i'm about 90% i'll be getting a 5.5g aga in about a week this tank just isn't quite how i want it so a fresh start will be nice.

anyways it's picture time:

some new growth

more growth


hilikus16 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome