Fluval Spec V - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 21 (permalink) Old 04-22-2013, 07:25 PM Thread Starter
Algae Grower
nwr2339's Avatar
Join Date: Jan 2013
Location: Mt. Pleasant, MI
Posts: 42
I was in the right place at the right time this weekend and was able to buy a 13W Fluval Mini Compact Florescence for my Spec V. I attached it on the side so it is over the plants that need more light. The thing is so bright however I was wondering if I should just remove the stock light or leave it the way it is.
nwr2339 is offline  
Sponsored Links
post #17 of 21 (permalink) Old 04-23-2013, 03:48 AM Thread Starter
Algae Grower
nwr2339's Avatar
Join Date: Jan 2013
Location: Mt. Pleasant, MI
Posts: 42
Starting today I am going to post a new pic every 5 days to document the growth/(decay lol) of my tank. I added the new light as you can see in the pick and I'm getting the feeling that the plants are going to really start flourishing. I'm doing a water change every other day and dosing with a bit of Excel.

nwr2339 is offline  
post #18 of 21 (permalink) Old 04-23-2013, 06:03 AM
Planted Tank Obsessed
vvDO's Avatar
Join Date: Oct 2010
Location: Richmond, CA
Posts: 429
Nice start, I just set up my spec V and the lights is almost non-existent. I am waiting on some eBay LED strips to either complement or replace the stock light.

Mr. Aqua 30cm cube journal
20L high tech journal
Fluval EDGE slightly modded, low tech
3+ gallon (40 x 16 x 20.5 cm) aquatic soil, low-tech
Fluval spec V (sitting in a box)
vvDO is offline  
post #19 of 21 (permalink) Old 05-17-2013, 03:08 AM Thread Starter
Algae Grower
nwr2339's Avatar
Join Date: Jan 2013
Location: Mt. Pleasant, MI
Posts: 42
Well I was going to post a pic every 5 days to show the progress but about two days later my Green Neons started showing ick. I proceeded to raise the temp to 86 for about 2 weeks. All the ick was gone for about 5-6 days so I removed the extra heater used to raise the temp as well as removed the plants that more or less completely deteriorated. The following 5 days everything was looking amazing again. fish were fine, the plants were flourishing but now I have a huge outbreak of snails, all of the neons have ick as well as the 2 oto cats. Between having ick again and the ridiculousness number of snails I'm about to cut my losses and start the whole tank. any suggestions? May try clout? With this small of a tank i am a bit afraid of using chemicals but I don't know what else to do.

I really don't want to mess with the plants though. They are all doing really good. Especially the bronze cryps that I added and the riccia fluitans on the driftwood.

Maybe I should just pull the fish, treat them and then....just live with the snails? I HATE HATE HATE SNAILS!!!!! The only way one would have gotten in to start with must have been one getting caught in the net....a very small one. Have I mentioned I hate snails?
nwr2339 is offline  
post #20 of 21 (permalink) Old 05-17-2013, 07:25 AM
Algae Grower
Join Date: Jan 2013
Location: North Yorkshire, UK
Posts: 132
Two assassin snails will deal with the pests and they won't multiply. There's loads on eBay for cheap

joey24dirt is offline  
post #21 of 21 (permalink) Old 06-09-2014, 04:01 AM
Planted Member
Join Date: Jan 2005
Location: hyannis
Posts: 200
Any update? love the look of your tank
second is online now  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome