Evolve LED Light problem - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-21-2013, 03:53 AM Thread Starter
Planted Member
Join Date: Sep 2011
Location: Mesa, Arizona, USA, Earth
Posts: 247
Evolve LED Light problem

Hi All
I have an issue with one of my Evolve 8's I was wondering if any of you may have seen before. The tank has been set up since September of last year, and recently I am having a problem with the light fixture. Some of the LED's have begun blinking off and on in unison over the last week. At first it was 3, today I see we're up to 5. The problem lights are all adjacent to one another. I'm hesitant to try to take the fixture apart, but if any of you have seem this before please let me know what you've done.


koiboi is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-21-2013, 04:18 AM
Planted Tank Enthusiast
Join Date: Mar 2013
Location: Revere, MA
Posts: 750
Led fixtures are pretty easy to put together. I've made two so far and they work well. Might be a loose wire somewhere?
dtejeda.arias is offline  

evolve 8, led

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome