Has your Fluval Spec ever leaked? - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 26 (permalink) Old 03-01-2013, 12:11 PM
Planted Tank Enthusiast
Jaguar's Avatar
Join Date: Oct 2011
Location: Kelowna BC, Canada
Posts: 838
Send a message via Skype™ to Jaguar
Originally Posted by MABJ View Post
What happened to everybody's lights?
The LEDs started dying one by one after only 2-3 months of use - they would flicker rapidly for a few days and then eventually go out. After 9 months, only about 1/3 of the lights work now, and 2 or 3 flicker. I just replaced it with a desk lamp.
Jaguar is offline  
Sponsored Links
post #17 of 26 (permalink) Old 03-01-2013, 03:31 PM
Invert Warrior
MABJ's Avatar
Join Date: Mar 2012
Location: NY
Posts: 3,883
Has your Fluval Spec ever leaked?

:O wow. I dunno if I have the super spec, but none of my lights have gone down. I feel maybe the lights have dimmed a little, but I'm one year strong now, so.

|Mossy Bonsai|Almost ADA|DBP Loonnng|CRS Spec|
|My Tanks ʌ | Shrimp advice v|
|Essential tools|List of inverts|Sage advice|Truth About Snails|
Mark A Belcher Junior, founder -- DBP Club.
MABJ is offline  
post #18 of 26 (permalink) Old 03-02-2013, 12:41 PM
Algae Grower
defender.TX's Avatar
Join Date: Jan 2013
Location: Austin, TX
Posts: 71
I've only had mine about 3 months but it has not leaked.
defender.TX is offline  
post #19 of 26 (permalink) Old 03-03-2013, 12:02 AM Thread Starter
Algae Grower
Join Date: Feb 2013
Location: Upstate New York - Albany Area
Posts: 42
Originally Posted by defender.TX View Post
I've only had mine about 3 months but it has not leaked.
Nice tank in your profile picture.
J2d2 is offline  
post #20 of 26 (permalink) Old 03-03-2013, 12:56 AM
Planted Member
Join Date: Feb 2012
Location: San Diego, CA
Posts: 251
my spec leaked from the back corner on top. just don't fill the spec all the way to the top.
chou is offline  
post #21 of 26 (permalink) Old 10-02-2014, 03:18 PM
Join Date: Oct 2014
Location: NYC
Posts: 1
Spec V wet along bottom??

I want to believe some overflow duty hole water changing saturated base and will eventually stop bleeding. But I notice wetness around base every day.
To the post who mentioned leak on bottom, exactly which seam or section of bottome sprung leak?
How can I test before totally dismantling tank?

Thanks - this is my first post .

Gemstoner@msn.com is offline  
post #22 of 26 (permalink) Old 10-03-2014, 03:15 AM
Algae Grower
difrent7's Avatar
Join Date: Nov 2012
Location: Tampa
Posts: 128
My Spec v is almost 2 years old and never had any sort of leaking issues. It is a solid little tank.
difrent7 is offline  
post #23 of 26 (permalink) Old 10-03-2014, 11:47 PM
Algae Grower
Join Date: Sep 2014
Location: Alexandria VA
Posts: 7
If anyone needs a spec V light I replaced mine with a finnex planted plus. Would prefer to ship US only and you just need to pay for shipping. Send me a pm
jt731 is offline  
post #24 of 26 (permalink) Old 10-04-2014, 03:20 AM Thread Starter
Algae Grower
Join Date: Feb 2013
Location: Upstate New York - Albany Area
Posts: 42
Leaked after 12 Months

Ironically after 12 months, my Spec II developed a slow leak from the bottom of the tank. Luckily it was a slow leak, it was probably like that for a good week before I noticed it.

In my opinion, I don't think the silicone sealer was that good.

Since the Spec has a 2 year warranty, Fluval replaced the tank for free!

I now have a new tank. It gave me a opportunity to start fresh.
J2d2 is offline  
post #25 of 26 (permalink) Old 10-04-2014, 08:56 AM
Planted Tank Guru
kman's Avatar
Join Date: Dec 2013
Location: Los Angeles
Posts: 2,350
My Spec 2G is about a year old. No leaks. It has made trips to and from the office twice in the past year (long holidays and vacations), and no problems to date. LEDs all work fine, too.
kman is offline  
post #26 of 26 (permalink) Old 10-04-2014, 03:55 PM
Algae Grower
Estima8tor's Avatar
Join Date: Aug 2014
Location: USA
Posts: 6
My spec 3 just sprung a slow leak around the bottom earlier this week after being set up for about 3 months. I moved everything into a 2 gallon bowl I got from Target and put the two shrimp I had in there in my speck2 gallon tank. To be honest, I think I may have caused the leak by pushing down to hard on a piece of driftwood I was moving so I can't say it was a flaw in the silicone.

Now I have a 2g bowl with a light. heater and co2 in it and I'm trying to decide what to do with it......

Estima8tor is offline  

fluval spec

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome