Please help ID fish problem - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-29-2013, 06:15 PM Thread Starter
Algae Grower
Join Date: Jan 2013
Location: UK
Posts: 20
Please help ID fish problem

hi guys

my neon tetra suddenly has this strange white growth / parasite. I dont think it's white spot as it purtrudes quite some was as if its some sort of parasite. nothing else in the tank shows any problems (yet!)

Any ideas?

Attached Thumbnails
Click image for larger version

Name:	tetra spot.jpg
Views:	214
Size:	62.5 KB
ID:	76594  

fluvaledge is offline  
Sponsored Links
post #2 of 5 (permalink) Old 01-29-2013, 06:27 PM
Wannabe Guru
Join Date: Jan 2013
Location: Humarock - Boston MA
Posts: 1,390
Is it cottony like or salt like? I'm on my phone its hard to see

I'm not into the image, but into the hobby...
CrypticLifeStyle is offline  
post #3 of 5 (permalink) Old 01-29-2013, 07:00 PM
Planted Tank Obsessed
Cinbos's Avatar
Join Date: Dec 2012
Location: Raleigh, NC
Posts: 363
Please help ID fish problem

I had this on one of my black neon tetras. It started off as a white bump, then began to look fluffy. It eventually fell off? And everything looked and seemed fine. Then a few days later he died. No other fish were affected by him either. Strange.

55 Gallon Planted

3 GBR, 2 Bolivian Rams, 1 Juvenile Super Red BN Plecos, 9 Oto Catfish, 9 Bloodfin Tetras
Rotala Indica, Cardamine, Crypt Spiralis, Pygmy Chain Swords, Dwarf Sag, Lutea Crypt, Wendtti Bronze and Red, and Floating Frogbit
Cinbos is offline  
post #4 of 5 (permalink) Old 01-30-2013, 07:30 PM Thread Starter
Algae Grower
Join Date: Jan 2013
Location: UK
Posts: 20
cottony like - today half of it has come off leaving a raised white patch!
fluvaledge is offline  
post #5 of 5 (permalink) Old 01-30-2013, 07:41 PM
Algae Grower
Public Alias's Avatar
Join Date: Mar 2012
Location: Gliese 581 g
Posts: 87
I have a neon tetra that had a bump like that - maybe a little smaller actually. The tetra flashed occasionally on my plants. I thought it might be ich. Whatever it was it disappeared over a month ago, and all my tetras seem fine now.

I don't remember there being a raised white patch though when it disappeared. You might want to consider some sort of broad spectrum antibiotic/antifungal bath for that tetra, because a raised white patch sounds like it could be an infection. Potassium permanganate comes to mind.
Public Alias is offline  

fish dying, identification, neon tetra

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome