Cupramine - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-24-2013, 03:46 AM Thread Starter
Algae Grower
Lfisher's Avatar
Join Date: Feb 2012
Location: Bellingham, Wa
Posts: 38

I've been treating my tank for the last several weeks for gill flukes and despite slowing increasing the concentration, my fish are still 'flashing'. Several ramshorn and apple snails seem unaffected and are even starting to re-produce. I removed the carbon prior to treatment and the last copper test read close to 3.0 mg/L (recommended copper concentration for treating freshwater is 0.25). I'm curious if any of the aquarium decor/media could be absorbing the the copper? Possibly peat??
Lfisher is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome