Sick platys - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-06-2012, 03:24 AM Thread Starter
Algae Grower
PTrader: (0/0%)
Join Date: Aug 2012
Location: KY
Posts: 87
Sick platys

I have 2 sunburst platys and 1 balloon molly who has been flashing. There are no signs of ich. Everyone's eating fine, there's been no new additions for months, and my parameters are

Ammonia 0
Nitrite 0
Nitrate 5 ppm (I have live plants)

My tank has been cycled for 6 months. I need suggestions. Should I possibly try the heat method? Medicate? I've tried to medicate not too long ago and it stopped. Maybe I need to try a different medication.

Any suggestions on meds would be very helpful.
Ljk09 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-06-2012, 06:29 AM
Planted Member
gabysapha's Avatar
PTrader: (1/100%)
Join Date: Oct 2011
Location: Ithaca, NY
Posts: 198
Flashing is just one symptom for many different ailments.

I think a general rule with anything is to not medicate until you have a better idea of what you're medicating for.

There are lots of articles about flashing all over the web, so I won't reiterate them here. If you google for this, for example I just googled "fish flashing" and the first hit I got was a great article overviewing multiple possible causes for flashing.
gabysapha is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome