Red patches on a single emperor tetra - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-04-2012, 07:25 PM Thread Starter
Algae Grower
Join Date: Sep 2012
Location: Boston, MA
Posts: 40
Red patches on a single emperor tetra

I've noticed in the past week that one of my male emperor tetra's has developed a red patch on his side. It is raised up against the body. I have no idea what it could be. Could anyone help me diagnose him? Sorry for the blurry image. It was taken with my phone.

biggerbang is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-17-2013, 11:43 PM
Algae Grower
Join Date: Jul 2010
Location: Wisconsin, USA
Posts: 59
I've had the same thing with two of my emperor's and I haven't been able to diagnose it. So far, I've had one of them manage to stay alive for a couple weeks somehow. The other one didn't make it.

From what I've been told, a salt bath is never a bad start to try to help the fish. I've never had much luck with adding medications to the water or putting my fish in a hospital tank.

Now that I think about it, I've seen something similar when I had rainbowfish.
snakeman1989 is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome