Molly has eggs outside body? - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 20 (permalink) Old 07-17-2012, 03:18 AM
Wannabe Guru
Join Date: May 2006
Location: Denville, NJ
Posts: 1,463
Originally Posted by Chrisinator View Post
It could be some sort or prolapsing, meaning parasites in the body.
X2. Treating my tank for Hexamita right now. Next is deworming...


><;;;"> <9))>>{

Eheim Pimp #204.
58 gal planted Oceanic
Red Turquiose Discus, Japonica shrimp, assorted Blue Eyed Rainbows, Tetras, Hatchets, Danios, Rasboras
10 gal low tech planted Celestial Pearl Danio (Celestichthys margaritatus) & Emerald Dwarf Rasbora (Microrasbora erythromicron)
LS6 Tommy is offline  
Sponsored Links
post #17 of 20 (permalink) Old 07-17-2012, 06:37 AM
Algae Grower
LaSirena's Avatar
Join Date: Jun 2012
Location: Ventura, CA
Posts: 39
You said that the male was chasing her earlier, maybe she was stressed and that is was caused her to go into premature birth? I have had that happen with live bearers before. I did not have enough females in my tank. I added some more, and everything was fine and she gave birth to healthy fry a few months later.

How is she doing today? Hope she is better!
LaSirena is offline  
post #18 of 20 (permalink) Old 07-17-2012, 06:46 AM
Planted Tank Enthusiast
Join Date: May 2011
Location: Stockton,CA
Posts: 861
I cant see the OP pic if there is one. Mobile version failure? Wish i could see these spots of interest!
DerekFF is offline  
post #19 of 20 (permalink) Old 07-17-2012, 03:18 PM Thread Starter
Algae Grower
Join Date: Jul 2012
Location: NY
Posts: 8
Thanks for the info everyone. Just so everyone knows, its not ich, as ive said before. The eggs have been completely aborted and she is good as new! Time to start waiting another 30 days for more "Platy" babies
vampyrechic is offline  
post #20 of 20 (permalink) Old 07-17-2012, 06:44 PM
Algae Grower
Join Date: Jun 2012
Location: NY
Posts: 39
Originally Posted by DerekFF View Post
I cant see the OP pic if there is one. Mobile version failure? Wish i could see these spots of interest!
Mobile version doesn't show images.pretty annoying
steveg89 is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome