The Planted Tank Forum - View Single Post - My treatment for spirogyra algae
View Single Post
post #10 of (permalink) Old 11-27-2012, 08:24 PM Thread Starter
Planted Tank Obsessed
AUvet14's Avatar
Join Date: Apr 2011
Location: Auburn, AL
Posts: 455
Originally Posted by TexasCichlid View Post
The problem with spirogyra is that you can have a prolific amount of it, but the root cause was temporary and simply a trigger regardless of how balanced your tank is currently. I had an outbreak I fought for a long time that started from am ammonia spike related to adding a handful of Amazonia to a relatively established tank, and with Tom's recommendation tried AlgaeFix. It worked beautifully and has not come back since.

I did remove my inverts, however, but saw no ill effects on my fish or plants after following the directions.
Thanks for sharing your experience. I guess in the future I could try to remove my inverts. Finding and catching them all seems like it would be a huge PITA, but I guess maybe not as big a pain as doing what I did.

Tom, thanks again for your response. I don't exactly know what my trigger might have been, but I'm sure overly dense plant growth leading to inadequate circulation, intense lighting, etc. played a role in exacerbating the problem. I'm fertilizing using EI method. While cleaning the tank, I did find 2 dead assassin snails. Idk if that would be enough of an ammonia spike to trigger the outbreak.
AUvet14 is offline  
For the best viewing experience please update your browser to Google Chrome