Tweeking the Tetratech for the 29g - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 17 (permalink) Old 03-12-2004, 07:47 PM
Doesn't like Kool-Aid
Momotaro's Avatar
PTrader: (52/100%)
Join Date: Feb 2003
Location: Hawthorne, New Jersey
Posts: 10,125
Momo always goes for the good stuff!!


Momotaro is offline  
Sponsored Links
post #17 of 17 (permalink) Old 03-24-2004, 10:23 PM
Planted Member
tommyboy22481's Avatar
PTrader: (0/0%)
Join Date: Mar 2004
Location: Madison, WI
Posts: 173
Originally Posted by Fat Guy
Tweeking the tetratech filter has (so far) kept bga out of my tank. I had the same problems that most people have with it- just creates too much surface agitation. Now, my surface agitation is miniscule and my underwater movement is ideal. Fat Guy
bga? do you mean blue green algae? I've had a big problem with that stuff while using a TetraTec.

I have just switched from the PF150 to a Fluval 204 cannister for many of the reasons you didn't like your TetraTec before you modified it. I think the siphon cap you removed was one of the biggest problems I had with my TetraTec. It just made so much noise!

The Fluval is whisper quiet, and so far my blue green algae levels have droppped drastically. Anybody want to buy a TetraTec PF150 with the built in heater?? :?:
tommyboy22481 is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome