Chads Arduino Build - Page 4 - The Planted Tank Forum
Reply
 
LinkBack Thread Tools Display Modes
post #46 of 74 (permalink) Old 03-12-2014, 04:19 AM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
Light done

So, I finished the light mod today. I did what AnotherHobby did almost exactly. The only difference is he used c-channel for the sides, and I used L-bracket. It ended up working very well, the sides now help keep the light spread from being annoying when sitting in the room. The light is directed downward much better now. Heres the pics of mine:

Light and stand with light turned off


With light turned on:


The underside where I made screwed the 1.5" aluminum piece to the legs:


And above that:



It took me about 3 hours to get it done. I had to use 3/8" rubber weatherstripping between the aluminum and the light to prevent light from leaking through. It sandwiched in there pretty well, it isn't very noticeable at all

Here's the link to AnotherHobbys mod: Fallen Tree Branch 60cm pg. 10

Last edited by Chiefston; 03-12-2014 at 04:20 AM. Reason: Added AnotherHobbys link
Chiefston is offline  
Sponsored Links
Advertisement
 
post #47 of 74 (permalink) Old 03-20-2014, 04:52 AM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
Update

So, I thought going in, that the wiring part would be fairly easy and straightforward. In actuality, the wiring part may have taken the longest of all! I attempted to keep my wires in check, but it didn't turn out quite as neat as I'd like. Oh well, I am almost done with the box. I have to attach the dosing pumps, and I will be finished with the project enclosure! I am going on vacation for the rest of the week, so I am hoping to have this all done and ready for planting next weekend
Heres some build pics:









Chiefston is offline  
post #48 of 74 (permalink) Old 03-20-2014, 03:05 PM
Planted Tank Enthusiast
 
Join Date: Nov 2013
Location: New York
Posts: 845
Awesome, build man. One day I'll build one of these. Hide all my equipment and focus on the scape more

-Chris
ctaylor3737 is offline  
post #49 of 74 (permalink) Old 03-20-2014, 06:26 PM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
Thanks Chris! It has been a much bigger endeavor than I anticipated. I have learned a ton during the build though, and it has been fun.


Sent from my iPhone using Tapatalk
Chiefston is offline  
post #50 of 74 (permalink) Old 03-20-2014, 09:37 PM
Wannabe Guru
 
Join Date: Apr 2012
Location: San Diego - CA
Posts: 1,012
is there a arduino script you can provide? i would like to build one of this myself but not sure where to begin i can look over the script and see if i can edit or change a few things to get it to work for what i need it too... great project tho
Bryanmc1988 is offline  
post #51 of 74 (permalink) Old 03-21-2014, 04:15 AM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
Bryan, I posted the code earlier in the thread. Feel free to download it and tweak it as you see fit


Sent from my iPhone using Tapatalk
Chiefston is offline  
post #52 of 74 (permalink) Old 03-21-2014, 04:50 AM
Wannabe Guru
 
Join Date: Apr 2012
Location: San Diego - CA
Posts: 1,012
ok i see it now lol skimming and passed it the first time xD thanks i will take a look into the code and see what its using and how it operates
Bryanmc1988 is offline  
post #53 of 74 (permalink) Old 03-23-2014, 02:23 AM
Algae Grower
 
Join Date: Jul 2012
Location: Canada
Posts: 42
Hi Chad,
Just wanted to say I've been following your build with a lot of interest.
Your code has helped me out a tonne to figure out some sequences for my own controller.
Please keep posting updates. I'd love to see the final version of your controller up and running!
Good luck with the wiring! (zip ties are your best friends)
Fluffles is offline  
post #54 of 74 (permalink) Old 03-25-2014, 05:37 AM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
Issues

Thanks for the kind words fluffles.

I have the project far enough along to begin final testing, and I seem to have run into a snag. I had planned on using the capacitive buttons, thus keeping the front of my stand clean (plus adding a little cool factor )
However, it seems that there is too much noise going on inside my project box, as the buttons keep hitting themselves repeatedly. The breakout board I bought from adafruit has a self-calibration feature, and it seems that the board keeps self calibrating itself too sensitive, and the buttons just go nuts. I'm not sure how to fix this, however if I can't find a solution I will just use regular old tact switches, and that will make me sad.
Chiefston is offline  
post #55 of 74 (permalink) Old 03-25-2014, 03:55 PM
Planted Member
 
Join Date: May 2011
Location: Portland, OR
Posts: 286
Have you tried posting your issue on the Adafruit forums? They are super helpful, and a lot of times you will receive responses from their engineers.

Sent from my Galaxy Nexus using Tapatalk
bigd603 is offline  
post #56 of 74 (permalink) Old 03-26-2014, 06:34 AM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
BigD, I did post a help thread on Adafruit, and they were very responsive and helpful. Looks like I will be relocating the capacitive board outside the project enclosure and just running the data wires back to the box. This should eliminate the problems I am having. It just so happened that while I was troubleshooting, I made a separate board just for the touch sensor, so that board will go right next to the buttons on the inside of my stand.
Here is my help thread:
Adafruit help forum

And here is the new board I made that I will be relocating outside the box
Chiefston is offline  
post #57 of 74 (permalink) Old 03-27-2014, 05:36 AM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
Working!

Ok, I finally have everything working like its supposed to I had to relocate the capacitance sensor board to the inside of my stand, but once I did that, it worked like a charm. I am using 1.5" x 1.5" copper clad board as my sensors, right now they're just taped to the inside. However, even as-is, they are sensing through 3/4" plywood. I am sure once they are securely screwed down they will work even better. Right now they work great, but only within a tight area.

Here's a pic from inside the stand, facing outward. You can see the LCD glowing on the right hand side:


I also made a quick video after I got the project working. It is kinda crap, as I took it quickly with an Iphone

Project Demo

So, the plan is to have the plumbing done, and plants ordered this weekend!!! As I live in Phoenix, I'm hoping that Arizona Aquatic Gardens is open for walk-ins, as they are only an hour drive away.

Stay tuned for more pics as things end up in their final resting places!
Chiefston is offline  
post #58 of 74 (permalink) Old 03-27-2014, 01:21 PM
Planted Member
 
Join Date: May 2011
Location: Portland, OR
Posts: 286
All I have to say is...holy crap that is awesome! I love the invisible buttons! Looks like Adafruits gonna get some more of my money today.

Sent from my Galaxy Nexus using Tapatalk
bigd603 is offline  
post #59 of 74 (permalink) Old 03-28-2014, 04:11 AM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
Ideas?

So, I'm having some issues trying to figure out how I'm going to plumb the dosing pumps into the filter hose lines.... The peristaltic pump tubing is 3/16" OD, which can be fit inside standard airline tubing, which is 5/32" ID. Then that leaves me with 1/4" OD tubing. I can get the standard press fittings, however I am somewhat nervous about using those, as I feel they may leak. However, finding barbed fittings for 1/4" OD tubing seems very difficult. I am lead to believe that airline tubing is 1/4" OD, 5/32" ID.
Any ideas here?
Chiefston is offline  
post #60 of 74 (permalink) Old 03-29-2014, 06:27 PM Thread Starter
Planted Member
 
Chiefston's Avatar
 
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
Box done

Here some pics of the box in its final form. There are a couple code changes I wanna make, now that I've had it running for a little bit. But the physical box is now complete!! Now just to figure out the plumbing situation....

Bottom. I drilled out the group of holes under the USB port for ventilation. The cheap-o box didn't really like having so many holes drilled so close together, and kinda splintered some.



Left side. The DIN connectors from left to right are: RGB lights; Buttons and temp sensor; LCD; LCD. The LCD takes 10 wires by itself.



Front. The red button on the right is wired to reset. It has come in handy as I troubleshot problems when moving from the breadboard to the box. I def recommend adding one to your box if you decide to make your own controller!



Right side. Self explanatory. Three dosing pumps, the #1 reason I built this thing! The tubing is 3/16" OD silicon tubing, which is not easy to find fittings for. Airline tubing fits pretty well over it, but I'm not to confident in that holding for extended periods of time. usplastics.com isn't the easiest site to browse, but I think they may have some sort of adapter to take this tubing to 1/4", which would make everything much much easier

Last edited by Chiefston; 03-29-2014 at 06:28 PM. Reason: forgot a pic
Chiefston is offline  
Reply

Tags
arduino, controller

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome