CO2 solution works, but not with air pump! - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-20-2013, 11:18 PM Thread Starter
Algae Grower
Join Date: Jun 2013
Location: Las Vegas, Nevada
Posts: 8
CO2 solution works, but not with air pump!

So this is my first DIY (or otherwise) experience with CO2 for planted tanks. I know my solution is working because my tubing will spit out bubbles, however once I try to hook it to my diffuser...a power head, my CO2 goes back several inches and just sits in the tubing. Do I need a different power head or is there an issue with my pressure or..?

Last edited by Natali3; 08-20-2013 at 11:40 PM. Reason: Oops! Sorry, not an air pump..meant powerhead..haha
Natali3 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 08-20-2013, 11:24 PM
Planted Tank Guru
Join Date: Jan 2010
Location: Contra Costa CA
Posts: 10,489
The yeast and sugar generates enough pressure to diffuse through an average bubbler, not a super fine one, though.

I do not see how to hook up an air pump to this. How are you doing that?
Diana is offline  
post #3 of 3 (permalink) Old 08-21-2013, 12:00 AM
Wannabe Guru
du3ce's Avatar
Join Date: Jan 2013
Location: colorado
Posts: 1,016
you need to put your difuser several inchest below the power head so that way the co2 will come through the suction hose of the power head and get spread out in the tank.
du3ce is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome