36" Ray II led replacement driver? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 12-13-2012, 07:11 PM Thread Starter
Planted Tank Enthusiast
 
VisionQuest28's Avatar
 
Join Date: Apr 2007
Location: Constantia, NY
Posts: 562
36" Ray II led replacement driver?

I have a 36" Ray II-DS that atleast one of the two driver boards burnt up. CS at finnex offered to TRY to convince the techs to repair it for free, if they deemed it repairable, there was no water damage, and i was willing to pay shipping both ways. I appreciate their offer, and i may end up going that route, but i would like to investigate other possibilities first. Soooo....

Does anybody know what driver I could purchase that would serve as a replacement? I am not sure what shape the other driver is in because i quit taking it apart once i saw how bad the first one is. But a replacement driver that was capable of driving both led boards would be best.

I am also not sure if the led's are even any good anymore. I dont see any obvious signs that they are bad or burned out, but i realize that doesnt mean anything. Any easy way to check with a multimeter? Or some other way?
VisionQuest28 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-13-2012, 07:33 PM
Wannabe Guru
 
jmhart's Avatar
 
Join Date: Mar 2008
Location: Atlanta,GA
Posts: 1,634
I have no answer for you, but out curiousity, how long have you had the fixture?
jmhart is offline  
post #3 of 8 (permalink) Old 12-13-2012, 07:39 PM Thread Starter
Planted Tank Enthusiast
 
VisionQuest28's Avatar
 
Join Date: Apr 2007
Location: Constantia, NY
Posts: 562
Quote:
Originally Posted by jmhart View Post
I have no answer for you, but out curiousity, how long have you had the fixture?
I purchased it second hand, i have no idea what led to this burning out. There was a manufacture date on the driver of 5/24/12 though
VisionQuest28 is offline  
post #4 of 8 (permalink) Old 12-14-2012, 12:57 AM
Planted Tank Enthusiast
 
O2surplus's Avatar
 
Join Date: Jan 2010
Location: "Out West, in the Land of Fruits & Nuts"
Posts: 813
Wow! 6 months old and drivers are already burning out? That doesn't sound promising.
Without knowing how the original drivers and leds were wired together it's anyone's guess if there's an off the shelf driver that would work. I'd love to take a stab at it though. How many leds and drivers does the unit contain? I may be able to offer some help if you can answer that?

225 Gal, Glass "Reef Ready" w/ twin Iwaki Pumps & 2 Ocean Clear inline filters.Lighting- Custom built DIY 600 watt LED system, BlueFish "mini" Led Controller,iAqua Aquarium Controller , and a 20lb CO2 system w/ Milwaukee Ph Controller.
O2surplus is offline  
post #5 of 8 (permalink) Old 12-14-2012, 10:18 AM Thread Starter
Planted Tank Enthusiast
 
VisionQuest28's Avatar
 
Join Date: Apr 2007
Location: Constantia, NY
Posts: 562
I Will have to look later today after work to give a definitive answer. But there are 2 drivers and 2 separate boards with multiple small led's , i would have to guess around 100 or so per board. Im pretty sure that the drivers are in series, but i Will have to look closer later today.

I got another email from finnex, the cs rep said that they definitely recommend sending the board in for repair. Said the tech claimed he had never seen a board burn up like that. They are def standing behind their product, and i believe they Will try to make it right. But i still don't think there is any guarantee that it is fixable, and Im kinda interested in tinkering with this some. So we Will see what happens...
VisionQuest28 is offline  
post #6 of 8 (permalink) Old 12-14-2012, 03:34 PM
Sponsor
 
Lowe's Avatar
 
Join Date: Nov 2011
Location: Chicago
Posts: 749
Hey VisionQuest28. Sorry about your fixture. What rep have you been conversing with? Do you know by any chance if the previous owner attempted to add a dimmer to the unit?
Lowe is offline  
post #7 of 8 (permalink) Old 12-14-2012, 04:01 PM Thread Starter
Planted Tank Enthusiast
 
VisionQuest28's Avatar
 
Join Date: Apr 2007
Location: Constantia, NY
Posts: 562
Hey Lowe,

I do not know which rep I am dealing with. I just read through all emails and there was never a name or number given. In the last email i received he/she asked the same question...if i knew if the last owner tried using a dimmer? I dont really have any info on how this was used.

I would like to say, that so far, in my limited dealings with Finnex I am very pleased and impressed. Knowing that I am not the original owner, that I dont have a receipt...they are still trying to help me. Thats a stand up company in my book! Thank you...
VisionQuest28 is offline  
post #8 of 8 (permalink) Old 12-14-2012, 05:14 PM
Sponsor
 
Lowe's Avatar
 
Join Date: Nov 2011
Location: Chicago
Posts: 749
Looks like you've been speaking to John. He'll take care of ya!
Lowe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome