Need help setting up my 65g aquarium - The Planted Tank Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-22-2016, 01:07 PM Thread Starter
Algae Grower
 
Join Date: Jul 2016
Location: Lansdale, Pa
Posts: 11
Setting up a 65 gallon

I need help

I need help with deciding plants and fish for 65 gallon aquarium

- 2 23 watt CFL equivalent to 100 watts (6500K)

20 gallon sump filter

- 350 bio-balls
- 1 1/10 pounds ceramic rings
- 1 pound of activated Carbon
- Blue and white poly filter pads floss 600 square inches

Substrate
- 0.5-1.0 inch of Organic Miracle grow soil s
- Small/Large Gravel
- Small bag of Eco-complete

Fish (so far)

- 1 Medium Clown loach
- 3 black tetras
- 3 red tetras

Plants so far

Jungly Val
Lily
Java ferns
Java moss
Amazonian swords
I honestly don't remember the name of the guy in the middle

I was wonder what ground covering plants I go get for my aquarium and is are my lights strong enough for what I have. Also if someone could just say I'm on the try track cause I have crazy algae on my drift wood and my water is still very yellow. Day 7 of cycling; 3 50% water changes

Photos of the set up and the algae on the dift wood. Could I get a few Siamese algae eaters to combat this algae?
Attached Thumbnails
Click image for larger version

Name:	image_1469204886858.jpg
Views:	6
Size:	38.6 KB
ID:	654585  

Click image for larger version

Name:	image_1469204946366.jpg
Views:	5
Size:	88.3 KB
ID:	654593  

Click image for larger version

Name:	image_1469204972690.jpg
Views:	5
Size:	52.4 KB
ID:	654601  

Click image for larger version

Name:	image_1469204999350.jpg
Views:	6
Size:	36.3 KB
ID:	654609  


Last edited by Darkblade48; 07-23-2016 at 09:11 AM. Reason: Please use the edit function for back to back posts to keep threads cleaner
CoreyDerk is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-23-2016, 07:10 PM
Planted Tank Guru
 
Hoppy's Avatar
 
Join Date: Dec 2005
Location: Sacramento, CA
Posts: 20,543
Since you are mostly asking about an "algae" problem I suggest asking for help in the algae forum. More people who are interested in algae will see the question.

Hoppy
Hoppy is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome