Pressurized CO2 with DIY mix.. need help please - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-12-2010, 03:37 AM Thread Starter
Algae Grower
Join Date: Apr 2010
Location: hartford,ct
Posts: 38
Pressurized CO2 with DIY mix.. need help please

i have a pressurized co2 canister. one of the hagen ones i think. its gray. anyway i just filled it with the normal amount of sugar to the first line then poured a small bag of yeast. after 10 minutes it started putting out tons of white stuff in it. and now the tank is super cloudy... did i put to much yeast or something?
truenoob is offline  
Sponsored Links
post #2 of 5 (permalink) Old 04-12-2010, 07:11 AM
Darkblade48's Avatar
Join Date: Jan 2008
Location: Toronto/Singapore
Posts: 9,867
The Hagen CO2 is not pressurized CO2, but simply DIY CO2.

Do you have a check valve between the DIY mix and your aquarium? From what it sounds like, your yeast mixture got into the tank. I would do several large water changes to get rid of the yeast first.

How much yeast did you use?


A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline  
post #3 of 5 (permalink) Old 04-12-2010, 08:19 AM
Wannabe Guru
Join Date: Dec 2004
Posts: 1,797
did you overfill the container...thats the only way it can get in there unless you tilted it or shook it
accordztech is offline  
post #4 of 5 (permalink) Old 04-12-2010, 12:46 PM
Planted Tank Guru
OverStocked's Avatar
Join Date: May 2007
Location: SoDak
Posts: 10,732
A bag of yeast? did you use the hagen pack or like a pack of bakers yeast... If bakers, you used too much. Likely you overfilled the hagen unit. And this is not "pressurized" co2.
OverStocked is offline  
post #5 of 5 (permalink) Old 04-13-2010, 03:42 AM Thread Starter
Algae Grower
Join Date: Apr 2010
Location: hartford,ct
Posts: 38
oh, no wonder when i googled diy yeast pressurized unit i was finding all the wrong things. lol. ya i put too much yeast. i just redid it after i let the water clear up. its crystal clear again thank god! thanks all!
truenoob is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome