HC-0810M Digital Temperature Controller - HELP!!! - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-29-2012, 03:14 PM Thread Starter
Planted Tank Enthusiast
PTrader: (15/100%)
Join Date: Jan 2012
Location: New York
Posts: 741
HC-0810M Digital Temperature Controller - HELP!!!

Hi Lowe,

Wanted to share something I came across today. Suddenly, HC-0810M would not turn on this morning. I opened it up, and noticed that the housing for the fuse is broken, and one of the connectors is simply inserted into it, holding on only by the spring in the fuse. It fell out finally after a few months of use, and thus controller would not turn on.

I am attaching a picture so that you can see where it's broken. Interesting item of note is that the piece that broke off wasn't inside the controller, which makes me think it was broken while being manufactured. He's what strikes me odd, in the respect of $60 controller, that part is probably 15c? Why would the company that builds them for you take that risk over such a tiny/cheap part.

Anyway, for the time being I stuck the connector back into the fuse and everything is fine for a temporary solution.

Best, nVladik

NIKON pimp #017
Sump pimp #014
nvladik is offline  
Sponsored Links
post #2 of 3 (permalink) Old 10-29-2012, 05:21 PM
Planted Tank Enthusiast
Lowe's Avatar
PTrader: (2/100%)
Join Date: Nov 2011
Location: Chicago
Posts: 742
Hi nVladik

When was that unit purchased? I can see a production date of 2011. We've never come across an issue such as yours and I'm surprised the unit was working up until now.

Send me a PM and we'll take care of ya!

PS. Here's the casing of a working unit we're using at the office.

Lowe is offline  
post #3 of 3 (permalink) Old 11-02-2012, 05:14 PM Thread Starter
Planted Tank Enthusiast
PTrader: (15/100%)
Join Date: Jan 2012
Location: New York
Posts: 741
Hi Lowe,

Thanks for getting back to the original post so quickly. So I temporarily fixed the controller, only to have it get knocked out by the hurricane for 5 days.

Unit was purchased in late April. I was also surprised to see what I saw, at the least I was expecting to find the broken piece inside. I am sending you a PM now.

NIKON pimp #017
Sump pimp #014
nvladik is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome