Aquatek Co2 MINI Regulator Broken??? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-08-2013, 06:43 AM Thread Starter
Planted Member
 
Charlieeex3's Avatar
 
Join Date: Aug 2013
Location: San Jose, California
Posts: 183
Aquatek Co2 MINI Regulator Broken???

I just receive my aquatek mini regulator today with a 20z paintball canister. After everything is set up. I plugged in my regulator and adjusted my co2 to a nice flow. In about 1 hour, the flow completely stopped and I have to turn my fine tuner again for co2 to come out. Does anyone have this problem as well?
Charlieeex3 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-08-2013, 06:51 AM
OVT
Carpe Diem
 
OVT's Avatar
 
Join Date: Nov 2011
Location: NorCal
Posts: 5,615
Your fine tuner (aka needle valve) could be "floating" / "drifting", which is not an uncommon problem. Try it for a day or so and, if the bubble count jeeps on changing, return the whole thing for exchange under warranty.

v3

Courtesy * Integrity * Perseverance * Indominable Spirit * and Self Control
Tenets of TKD
OVT is offline  
post #3 of 7 (permalink) Old 10-08-2013, 07:10 AM Thread Starter
Planted Member
 
Charlieeex3's Avatar
 
Join Date: Aug 2013
Location: San Jose, California
Posts: 183
Thank you for replying quickly. I was losing my patience today. I had to change the needle valve 5+ times already and it's very annoying. I'm going to give it a day and see what happens
Charlieeex3 is offline  
post #4 of 7 (permalink) Old 10-09-2013, 02:31 AM
Algae Grower
 
jmeister's Avatar
 
Join Date: Sep 2009
Location: Lexington, KY
Posts: 59
What is the tank PSI? I had lots of trouble keeping a consistent flow on a highly pressurized tank with that regulator, finally worked better once pressure lowered towards the green.
jmeister is offline  
post #5 of 7 (permalink) Old 10-09-2013, 11:47 PM Thread Starter
Planted Member
 
Charlieeex3's Avatar
 
Join Date: Aug 2013
Location: San Jose, California
Posts: 183
It was at max when I refilled the bottle. I noticed it got a lot better now but I still have to adjust it a few times but not as much. 2 days ago my tank had 1500 psi, after 2 days it's at 1000 psi. Is this normal? Or do I have a leak. I thought this tank would last me 2 months but it already went down 500 psi in 2 days
Charlieeex3 is offline  
post #6 of 7 (permalink) Old 10-11-2013, 07:20 AM Thread Starter
Planted Member
 
Charlieeex3's Avatar
 
Join Date: Aug 2013
Location: San Jose, California
Posts: 183
The needle valve issue did not get any better. The needle valve isn't suppose to be adjusted every few hours. Is there a way to fix this? I read many reviews on this regulator and seems like half of the people don't have this problem and the other half do. I'm really losing my patience with this regulator. Anyone else have this problem? If so how did you fix it
Charlieeex3 is offline  
post #7 of 7 (permalink) Old 10-11-2013, 09:39 AM
OVT
Carpe Diem
 
OVT's Avatar
 
Join Date: Nov 2011
Location: NorCal
Posts: 5,615
I would call the place you got it from or the manufacturer.

v3

Courtesy * Integrity * Perseverance * Indominable Spirit * and Self Control
Tenets of TKD
OVT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome