Up dated pics - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-29-2003, 03:19 AM Thread Starter
Algae Grower
PTrader: (0/0%)
Join Date: Dec 2002
Location: vancouver. B.C.
Posts: 45
Send a message via MSN to qbal18
i have ripped a bunch of stuff out and added a few new plants however i also have a few plants that arnt doing that good i put pics

(Im#1)first my sword id dose not grow big leafs just narow ones
(Im#2)some other plant i dont know or what is wrong with it
(Im#3)some other plant i dont know or what is wrong with it

also what can i do to get this grass to groww better i just got it and i really want it to do good
i dont really have any substrate, i have 3wpg diy co2



qbal18 is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
New pics of my 55 dogg76 Tank Journals 13 09-17-2004 09:07 PM
Pics of my 90 Gallon so far. Aquaman Tank Journals 9 03-16-2004 05:46 PM
Tons of huge pics (huge post, dial-up shouldn't bother) Joe Schmoe Fish 8 02-02-2004 05:49 AM
DIY canopy: initial pics for now, step by step to follow jart DIY 9 04-20-2003 01:13 AM
3 Gallon Pics Pooky125 Tank Journals 12 01-28-2003 08:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome