In Need Of Help With Aquarium Cycle! - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-25-2013, 11:14 PM Thread Starter
Algae Grower
Join Date: Dec 2013
Location: California
Posts: 21
In Need Of Help With Aquarium Cycle!

So I set up my new tank on Monday the 23rd, and did a fishless cycle by adding some fish flakes.

On Tuesday, I tested my Ammonia levels and got a reading of .50ppm. I then added a few fish flakes and also got some water from my local fish store who had excellent reviews and was very helpful.

Today, I just tested again and my readings were

Ammonia - 0.25ppm
Nitrite - 0 ppm

I'm pretty confused on why my Ammonia levels dropped, my tank also looks a LITTLE bit milky/cloudy.

Is there any suggestions on what I should do?

I also didn't add any Seachem Stability or Prime yet.
softmushroom is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-26-2013, 12:42 AM
Planted Tank Obsessed
vvDO's Avatar
Join Date: Oct 2010
Location: Richmond, CA
Posts: 429
You'll probably start seeing some nitrites in 2-3 weeks. Possible your measurement is a bit off... Not much of a difference between 0.25 and .5

Mr. Aqua 30cm cube journal
20L high tech journal
Fluval EDGE slightly modded, low tech
3+ gallon (40 x 16 x 20.5 cm) aquatic soil, low-tech
Fluval spec V (sitting in a box)
vvDO is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome