Help me identify this algae/build up. - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-28-2013, 05:37 PM Thread Starter
Algae Grower
Join Date: Mar 2013
Location: California
Posts: 6
Help me identify this algae/build up.

*I'm sorry, just realized I may have posted this in the wrong forum"

Hi everyone. Just started my first Iwagumi a few weeks ago. I started to notice this growth or build up on my rocks. I've dealt with almost every type of algae in my previous tanks but I have never seen this before.

It is almost the same color as the substrate, Amazonia Soil. It seems to dissolve when I scrape it off. It is also weird how it is appearing on the rock, almost in a set pattern.

Could this just be build up of free floating soil particles? Or is this some type of algae I need to be ready to combat? Or something entirely different?



eightb8ll is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome