125 MTS topped with 'baylees better bottom" - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-28-2011, 01:56 AM Thread Starter
Algae Grower
Join Date: May 2011
Location: delaware
Posts: 118
125 MTS topped with 'baylees better bottom"

My first planted tank...Somebody gave me a 15 gal metaframe tank in 1975 and I started with angelfish ....on to saltwater in '78...reefs in the 80's & 90's...now..back to where it all began -freshwater...never kept plants before...
Tank specs : 125 marineland with 1500 gph glass holes overflow drilled..
2 40 gal bdr sumps with 200 micron filter socks linked together..
emperor aquatics 25 watt Uv -slow flow about 100 gph
aquaricare algae scrubber on an RDP cycle with the main tank
eheim 1262 return pump
aquariumplants.com Co2 reactor & regulator
I don't add anything yet,just large (80 gal) water changes every 3 months..
substrate- some company called aquarisms (no longer in business)was selling MTS pre made packages-I bought one because I was too lazy to mineralize it myself
Baylees better bottom Cap ...great stuff-but no longer available
lights-gieseman aquaflora, plus actinic white uvl bulbs in a 4 lamp t5ho unit..
anyway here's some crude photos...any good for a first attempt?

ft shots:

right side:

left side:

aquatic serenity is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome