Very High Nitrite - Help! - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 18 (permalink) Old 05-05-2013, 08:57 AM Thread Starter
Planted Member
Neptoon'd's Avatar
Join Date: Apr 2013
Location: Skinners Mudhole
Posts: 206
Thanks zorfox and puopg. I'm cultivating my patience. I am so impatient because I don't want any more losses. I noticed a new molt before I changed the water.

My second pwc brought the nitrites to maybe a 1? Anyway it was lighter purple than the crazy dark stuff I've normally been testing. I'll do another pwc (2g) in the late morning.
Neptoon'd is offline  
Sponsored Links
post #17 of 18 (permalink) Old 05-05-2013, 09:57 PM Thread Starter
Planted Member
Neptoon'd's Avatar
Join Date: Apr 2013
Location: Skinners Mudhole
Posts: 206
I tested the water before the first pwc today. It was in the lighter purple, like a 1 or so. After the pwc of 2 gal the reading was still elevated. I'll do another 2 gal pwc tonight. Working on patience. Hoping to really see the nitrite levels staying low like this. The lighter purple has to mean I'm making progress. If I can keep the levels from getting back into the dark purple I'll feel like I'm making progress.
Neptoon'd is offline  
post #18 of 18 (permalink) Old 05-06-2013, 09:08 AM Thread Starter
Planted Member
Neptoon'd's Avatar
Join Date: Apr 2013
Location: Skinners Mudhole
Posts: 206
Can I jump up and down for a minute? I just tested the water after my 2nd 50% pwc today. My nitrites are negligible! Not the pale blue, but a really light purple I guess. I've been feeling like Sisyphus, repeating the same task over and over and feeling like I'm not truly gaining ground. Of course this isn't a meaningless task. But you get the drift I'm sure.

Anyway, I'm not stopping now! No way! I'm going to keep doing 2x daily 50% pwc until I'm only seeing nitrates and no nitrites. And then I'll likely continue for a few days after as well. My nitrates have been holding steady and no ammonia. So I'm still a bit confused how my nitrites have remained so high despite changing all but 1gal of the water every day? I'm not dosing ferts and I don't think there is a root tab still in there.

And I'm bummed cuz I found another dead shrimp earlier. It was one of the two low grade cherries I have left. The rest are sakura and pfr grade.

More good news is I think my tds pen will arrive tomorrow! Its that or the purigen.

When I get the purigen, would it be OK to remove the carbon in my filter and replace it with the purigen bag? I would be fine with leaving the carbon bag in the tank for a while so I wouldn't lose all that beneficial bacteria right as I'm hopefully achieving balance.
Neptoon'd is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome