CSM+B mixture is cloudy - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 02-20-2013, 01:22 PM Thread Starter
Algae Grower
 
Join Date: Jun 2011
Location: US
Posts: 139
CSM+B mixture is cloudy

I opened my thermos of CSM+B today and discovered that it had a strange haze floating in it. I have put the recommended amount of Excel into the mixture to prevent mold. The mixture is kept in a stainless steel thermos so no light gets to it. My question is has anyone experienced mold in their mix even after using excel?
bat_billy is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 02-20-2013, 11:32 PM
Planted Tank Enthusiast
 
Join Date: Aug 2012
Location: Connecticut
Posts: 562
I've had that happen to both a solution of Miller's microplex plus glutaraldehyde (should have worked even better since I didn't adjust for the concentration difference) and a solution of potassium sulfate and monopotassium phosphate (which, being a macro mix, wasn't supposed to be mold prone). I give up - I dose dry now even for little tanks. If I need less than 1/64 tsp of anything, I just dose less often. Much less fuss and I never have to throw anything away.
chibikaie is offline  
post #3 of 10 (permalink) Old 02-20-2013, 11:46 PM
Planted Tank Guru
 
happi's Avatar
 
Join Date: Dec 2009
Location: Salt Lake City, UT
Posts: 2,953
Send a message via Yahoo to happi
Quote:
Originally Posted by bat_billy View Post
I opened my thermos of CSM+B today and discovered that it had a strange haze floating in it. I have put the recommended amount of Excel into the mixture to prevent mold. The mixture is kept in a stainless steel thermos so no light gets to it. My question is has anyone experienced mold in their mix even after using excel?
yep i get fungus even when adding excel to the solution, next time add some vinegar to the solution, you can also add ascorbic acid and potassium sorbate to keep the solution fresh and fungus free.
happi is offline  
post #4 of 10 (permalink) Old 02-21-2013, 12:34 AM
Moderator
 
Darkblade48's Avatar
 
Join Date: Jan 2008
Location: Toronto/Singapore
Posts: 10,345
The best solution I have found so far is using hydrochloric acid

Please be careful and take the necessary precautions if handling it.

Anthony

A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline  
post #5 of 10 (permalink) Old 02-23-2013, 07:36 PM Thread Starter
Algae Grower
 
Join Date: Jun 2011
Location: US
Posts: 139
Re: CSM+B mixture is cloudy

Quote:
Originally Posted by happi View Post
yep i get fungus even when adding excel to the solution, next time add some vinegar to the solution, you can also add ascorbic acid and potassium sorbate to keep the solution fresh and fungus free.
Do you have the ratio of vinegar to solution?

For example: 5 ml of vinegar for every 250 ml of solution.

Also, I assume you are using white vinegar.
bat_billy is offline  
post #6 of 10 (permalink) Old 02-23-2013, 07:38 PM
Planted Tank Obsessed
 
Join Date: Feb 2013
Location: NH USA
Posts: 309
CSM+B mixture is cloudy

Been using CSM+B with a little mold growing in it for about 12 years and the mold never hurt anything


Sent from my iPad using Tapatalk HD
Fishmommy is offline  
post #7 of 10 (permalink) Old 02-23-2013, 07:48 PM
Planted Tank Guru
 
Join Date: Jan 2010
Location: Contra Costa CA
Posts: 11,721
Ditto fishmommy: A little mold never hurt anything. If it gets so dense the syringe won't pick up the fertilizer then you are not using it fast enough, or making too much and storing it for too long.
Diana is offline  
post #8 of 10 (permalink) Old 02-23-2013, 10:26 PM Thread Starter
Algae Grower
 
Join Date: Jun 2011
Location: US
Posts: 139
Re: CSM+B mixture is cloudy

Quote:
Originally Posted by Fishmommy View Post
Been using CSM+B with a little mold growing in it for about 12 years and the mold never hurt anything


Sent from my iPad using Tapatalk HD
I used it for about a week with the mold and I didnt have any problems at all. I dont know if using moldy trace mix is safe or not. I honestly dont want to take the chance of it infecting the tank or fish.
bat_billy is offline  
post #9 of 10 (permalink) Old 02-23-2013, 11:42 PM
Planted Tank Enthusiast
 
Join Date: Sep 2012
Location: Sacramento, CA
Posts: 765
I dunno if this is bad but i keep mine in the fridge. No mold after 3 weeks.
puopg is offline  
post #10 of 10 (permalink) Old 02-23-2013, 11:48 PM
Planted Tank Guru
 
Join Date: Aug 2010
Location: Houston
Posts: 2,261
I used ~200mg Ascorbic acid to 500ml of water in my GH booster, Fe Gluconate and CSM mixtures. Does okay there. I just took a 250mg vitamin C pill and ground it up for the acid. Works excellently. Refrigeration is also a good option btw. Most fungus really hate acidity. Around 4 or less pH should stop it.

Quote:
Originally Posted by puopg View Post
I dunno if this is bad but i keep mine in the fridge. No mold after 3 weeks.
Jeffww is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome