treating GSA - The Planted Tank Forum
 6Likes
  • 1 Post By Pocky
  • 1 Post By ilovekillis0852
  • 2 Post By dukydaf
  • 1 Post By essabee
  • 1 Post By JuanPeces1508
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-16-2015, 07:46 AM Thread Starter
Algae Grower
 
Join Date: Nov 2015
Posts: 17
treating GSA

hi
i,m treating GSA in my low tech tank (I posted a topic last month here)
I'm dosing brightwell florin phosphorus and lowered my light .
the problem I have is about more than half of my plant's leaves are infected. and I really dont want to cut them . Can I treat without cutting leaves?
does anybody have any experience about this algae?
masoudj021 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-18-2015, 04:38 PM
Algae Grower
 
Join Date: Nov 2015
Posts: 15
You can try flourish excel. It's not marketed as an algaecide but one of it's known effects is it kills algae. I wouldn't overdose it though, just go with the regular daily dose. After a week or so it might start clearing. If you want faster results get a syringe and turn off the filter, and squirt excel right on the algae. DO NOT overdose. Just use the regular daily dose.
masoudj021 likes this.
Pocky is offline  
post #3 of 10 (permalink) Old 12-18-2015, 09:27 PM
Algae Grower
 
Join Date: Dec 2015
Posts: 19
looks like you have a unbalaced tank, i would increase po4 dosage, do you add other fertilizer apart from po4?

Bump: looks like you have a unbalaced tank, i would increase po4 dosage, do you add other fertilizer apart from po4?
masoudj021 likes this.
ilovekillis0852 is offline  
post #4 of 10 (permalink) Old 12-19-2015, 07:26 AM
Planted Tank Obsessed
 
dukydaf's Avatar
 
Join Date: Dec 2004
Location: Munich
Posts: 441
Send a message via Yahoo to dukydaf
If the algae is on something like Anubias, where one leaf is a 2 week investment, just leave the leaf there. If PO4 levels are high enough the algae won't propagate. For me it went away on its own from some old leaves...
Hoppy and masoudj021 like this.
dukydaf is offline  
post #5 of 10 (permalink) Old 12-19-2015, 12:48 PM
Wannabe Guru
 
essabee's Avatar
 
Join Date: Oct 2006
Location: Ranchi, Jharkhand, India
Posts: 1,009
You could do a 72 hour blackout.

A water change, feed the fishes, dose the phosphate, do the blackout, water change again, and go with lights and excel/metricide. I think that your problem will go away.

PS - Calculate the phosphate dose to 2 ppm and see if you need potassium too.
masoudj021 likes this.

If you have a choice, you have a problem, till you elect your choice. No choice, no problem, only consequences, learn to live with them.
essabee is offline  
post #6 of 10 (permalink) Old 12-20-2015, 04:41 AM
Algae Grower
 
Join Date: Dec 2015
Posts: 17
checkout rotala butterfly fertilator and calculate for low light ei dosing for phosphate
masoudj021 likes this.
JuanPeces1508 is offline  
post #7 of 10 (permalink) Old 01-21-2016, 01:16 PM Thread Starter
Algae Grower
 
Join Date: Nov 2015
Posts: 17
new update:
Im dosing phosphate and increasing plants. GSA was being removed from leaves.
But two days ago I bought a magnet glass cleaner and cleaned remaing GSA from front glass. next day GSA had covered nearly all top leaves. Is this because of those GSA removed by magnet?
masoudj021 is offline  
post #8 of 10 (permalink) Old 01-21-2016, 03:05 PM
Planted Tank Obsessed
 
dukydaf's Avatar
 
Join Date: Dec 2004
Location: Munich
Posts: 441
Send a message via Yahoo to dukydaf
Maybe. Did you perform a water change after the algae cleaning ?

Could you describe your PO4 dosing ? concentration in aquarium , amount, frequency ?

It might be that the levels in the aquarium became lower ( plant uptake, wc,...)
dukydaf is offline  
post #9 of 10 (permalink) Old 01-22-2016, 06:55 AM Thread Starter
Algae Grower
 
Join Date: Nov 2015
Posts: 17
Quote:
Originally Posted by dukydaf View Post
Maybe. Did you perform a water change after the algae cleaning ?

Could you describe your PO4 dosing ? concentration in aquarium , amount, frequency ?

It might be that the levels in the aquarium became lower ( plant uptake, WC,...)
I do 10% WC per week or two weeks.
I'm dosing 20 drops of Brightwell florin P each day. I don't have tester. plants are stocked well IMO.

Last edited by masoudj021; 01-22-2016 at 07:46 PM. Reason: mistype
masoudj021 is offline  
post #10 of 10 (permalink) Old 02-07-2016, 05:59 AM
Algae Grower
 
Join Date: Dec 2015
Posts: 19
masoudj021, please give us your tank specs and a picture, so we could give you a better advice. Plant need macros and micros for them to thrive. Dosing PO4 alone will not solve your algae issues.
ilovekillis0852 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome