My Experience with Aquaticlife Four-Lamp T5-HO - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-29-2013, 09:16 PM Thread Starter
Planted Tank Enthusiast
 
sundragon's Avatar
 
Join Date: Jan 2011
Location: Washington, DC
Posts: 516
Thumbs up My Experience with Aquaticlife Four-Lamp T5-HO

Hello All, not a review but my 2 on my experience with my Aquaticlife Four-Lamp T5-HO 39w unit.

I bought the unit in March of last year when I set up my tank. The unit was priced right, 2 banks of T5-HO and 1 bank of blue LEDs, all three on a separate digital timer.

Up till now the unit has performed reliably and the plants show it.

A week ago, I noticed the channel for the LEDs came on but no blue LEDs lit up. I called Aquaticlife and after a brief hold a human being answered and walked me through how to open the panel and check the power supply for the LEDs. It appears the power supply died, without any fuss he offered to send me a replacement.

Just a bit of background: I'm an IT guy, I've worked in IT since 1992 and having a human being answer the phone to give you tech support, and then offer to send you a replacement without any fuss is nearly unheard-of!

I see people asking for recommendations on equipment on here - I was one of those people a little over a year ago, their customer service speaks volumes.

You can see my tank on my link below
sundragon is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome