Faulty Lighting - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-12-2012, 07:04 AM Thread Starter
Algae Grower
PTrader: (0/0%)
Join Date: Jun 2012
Location: Australia
Posts: 6
Faulty Lighting

Have had a set of lights with 6x24w HO lights for maybe three years on a marine setup but now it keeps blowing the whole power board every time i plug it in to a socket. If I can fix it I would use it for a planted setup. Can anybody please help!!!
amphiprion is offline  
Sponsored Links
post #2 of 3 (permalink) Old 06-12-2012, 12:34 PM
Planted Tank Guru
Craigthor's Avatar
PTrader: (188/100%)
Join Date: Sep 2007
Location: Dubuque, IA
Posts: 9,628
my guess is some corroded wiring that is shorting it out. Take it apart and take a close look at all the wiring and connections. Possibly some salt creep in there that is the issue.


Originally Posted by cdwill View Post
"C'mon, they're just plants, man, no big deal -- try some"
Craigthor is offline  
post #3 of 3 (permalink) Old 06-13-2012, 11:27 AM Thread Starter
Algae Grower
PTrader: (0/0%)
Join Date: Jun 2012
Location: Australia
Posts: 6
thanks ive sent it to the electrician anyway but it seemed pretty rusted out
amphiprion is offline  

blows, broken, dangerous, faulty, lights

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome